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Document outline 

About	the	drawing	protocol	document	

Govt.	of	Rajasthan	has	automated	the	building	plan	approval	process	by	introducing	AutoDCR	system.	
AutoDCR	 software	 reads	 the	 CAD	drawings	 submitted	 by	 architects	 and	 automatically	 produce	 the	
compliance/	deviation	report	i.e.	scrutiny	report	based	on	the	control	regulations	prescribed	by	state	
government.		

The	 purpose	 of	 this	 document	 is	 to	 establish	 a	 set	 of	 guidelines	 for	 Architects	 to	 assist	 them	 in	
preparation	 of	 drawings	 (.DWG)	 to	 be	 submitted	 online	 for	 obtaining	 Building	 Plan	 Approval	 from	
respective	 authorities.	 Uniformity	 in	 the	 process	 of	 drafting	 of	 the	 drawings,	 to	 be	 submitted	 for	
approval,	is	required	for	automation	of	building	plan	approval	system.		

The	 Consultants/	 Architects	 should	 prepare	 the	 drawings	 keeping	 specific	 objects	 in	 specific	 layers	
with	specific	colors	and	text.		The	layers	required	to	be	generated	with	explanation	of	what	is	required	
to	 be	 drawn	 on	 which	 layer	 is	 described	 in	 this	 document.	 This	 document	 serves	 as	 a	 source	 of	
information	on	obtaining	 level	of	 consistency	 in	drafting	and	approval	process	 focuses	on	both	 the	
theoretical	and	practical	description	of	process	flow	and	protocol	to	be	used	while	preparing	drawings	
for	submission.		

The	 Consultants/	 Architects	 can	 prepare	 drawing	 file	 with	 the	 help	 of	 this	 document.	 Document	
contains	following	three	sections:	-	

Ø Creation	of	standard	layers	manually	in	CAD	software	
Ø Use	of	Drawing	Template		
Ø Use	of	PreDCR	utility		

	

	How	to	read	this	drawing	protocol	document?	

This	document	should	be	read	in	conjunction	with	the	building	bye-laws	which	will	be	applicable	for	
approval	of	a	proposal.		The	reader	of	this	document	should	have	understood	the	applicable	bye	laws	
for	scrutiny	of	a	proposal.	The	reader	should	also	be	familiar	with	CAD	terminology	and	environment	
for	better	understanding	of	 the	system.	 It	 is	more	exploratory	 in	nature	than	the	specifications	and	
contains	sections	to	explain	particular	aspect	of	planning	and	designing.	
	



Approach	for	preparing	drawing	using	set	guidelines/protocol	

AutoDCR	 is	 a	 unique	 and	 innovative	 approach	 to	 automate	 scrutiny	 of	 building	 proposals	 by	

reading	 CAD	 drawings.	 AutoDCR	 software	 needs	 preformatted	 drawings	 with	 some	

specifications.	 Applicant/	 Architect	 can	 choose	 any	 of	 the	 following	 3	 options	 to	 prepare	 his	

drawing	in	the	required	format.	

Option	1-	Architect	can	refer	list	of	layer	names	and	respective	layer	colors/	text	provided	in	the	

chapter	1	of	this	document	and	prepare	the	layers	manually	using	CAD	software’s	layer	creation	

commands	(Reference:	Section	1).	

	Option	2-Architect	can	download	‘Standard	CAD	drawing	template	file’	(Drawing	Template.dwg)	

file	from	SWCS	Portal.	All	the	layers	required	for	preparing	submission	drawing	will	be	available	

in	 this	 template	 drawing.	User	 can	prepare	drawing	using	 these	pre-generated	 layers	 and	 text	

protocol	defined	in	the	protocol	document.	(Reference:	Section	2).			

	Option	 3-	 Architect	 can	 download	 a	 CAD	 based	 utility	 from	 URLs	 below.	 Using	 this	 utility,	

architect	can	create	required	layers	automatically	in	the	drawing,	insert	required	text	and	objects	

in	the	drawing.	This	utility	will	also	check	drawing	integrity	and	highlight	drafting	errors	present	

in	the	drawing.	(Reference:	Section	3).			

https://swcs.rajasthan.gov.in/BPAS/UploadDrawPre/PreDCR_RAJASTHAN_32BIT.rar (32 bit) 
 
https://swcs.rajasthan.gov.in/BPAS/UploadDrawPre/PreDCR_RAJASTHAN_64BIT.rar (64 bit) 
	



Section I 

Creation	of	standard	layers	manually	in	AutoCAD	

The	consultants/Architects	to	prepare	the	drawings	keeping	specific	objects	on	specific	layers	with	
specific	colors	code	and	text.	User	to	create	layers	manually	in	any	CAD	software	and	assign	layer	
name,	color	and	text	manually	as	defined	in	the	table	below:	

	Drawing	protocol	layer	list	and	related	properties	

Sr.	
No.	

Layer	Name	 Color/Color	
index	

Text	 Line	Type	 Drawing	
Domain	

Remarks	

1	 _Amenity	 Cyan	 AMENITY	 ByLayer	 Inside	of	Plot	
poly	line	

Text	should	be	provided		
on	same	layer	and	color.		

2	 _ArchProj		 24	 CHAJJA	 ByLayer	 Inside	of	Floor	
Polyline	and	
overlapped	
with	any	FSI	
polyline	

All	types’	projection	to	be	
drawn	on	same	layer	like	
chajja,	Flower	bed,	
cornice,	loft,	etc.		
Default	color	of	this	layer	
is	“21”	

21	 OTTA	
21	 STEPS	
23	 C.B.	
22	 F.	B.	
24	 CANOPY/POR

CH	
26	 LOFT	
21	 ARCHPROJ	

3	 _Balcony	 25	 BALCONY	 ByLayer		 Inside	of	floor	
but	Outside	
overlapped	
with	any	FSI	
Polyline		

Balcony	projection	to	be	
drawn	on	_balcony	Layer	
with	respective	text	and	
color.		
Default	color	of	this	layer	
is	“25”	

230	 (ENC)	
BALCONY	

4	 _Building		 52		
	

A	(BUILDING)		
	

ByLayer		
	

Outside	of	
Plot	Polyline		

Provide	building	name	
with	matching	with	its	
proposed	work	which	is	
shown	in	layout.		

5	 _BasementLine	 173	 BASEMENT	
LINE	

ByLayer		
	

Inside	of	Plot	 Draw	polyline	to	
represent	basement	line	
in	plot.	

6	 _CarpetArea	 191	 101,	102,	etc.		
	

ByLayer		
	

Inside	of			
Floor	/	FSI	
Polyline		

Give	text	of	units	no	If	
normal	dwelling	units.		

191	 SPLIT	01,	
SPLIT	02,	etc.		

ByLayer		
	

Inside	of		
Floor	/	FSI	
Polyline		

Give	text	of	units	no	if	it	
is	splitted.		

7	 	_Chowk	 180		 CHOWK		 ByLayer		 Inside	of	Floor	
/	FSI	Polyline		

Text	should	be	kept	on	
same	layer	and	color.		

8	 _CommArea	 150		 NA	 ByLayer	 Inside	of	Floor	
Polyline		

No	need	of	text	for	this	
layer.			
Default	color	of	this	layer	
is	“150”	

200	 NA	 ByLayer	 Color	should	be	200	if	it	
is	existing	area	

9	 _CompoundWall	 252	 1.50m	High	
Comp	Wall.		

ByLayer	 Overlap	with	
Plot	poly	line		
	

Need	to	mention	
compound	wall	height	in	
its	text.		

10	 _Door	 114		
	

D1,	D2,	D3,	
etc.		

ByLayer		 Inside	of	Floor	
/FSI	
/Substructure	
Polyline		

Need	to	provide	D1,	D2,	
D3,	text	to	calculate	no	of	
doors	and	its	text	should	
be	inside	door	poly.		

11	 _DrainLine	 51	 DRAINAGE	
LINE	

ByLayer	 Inside	of		plot	
poly	line	

Poly	line	should	be	drawn	
as	open	polyline	and	



12provide	its	text	with	
intersecting	open	
polyline	on	same	layer	
and	color		

12	 _Electline	 241		 33	KV	High	
Tension	Line		

ByLayer		 Inside/interse
ct	with	Plot		
	

Need	to	mention	voltage	
of	the	electric	line	in	its	
text.	

13	

	

_ExStructure	 Blue	 Existing	
building1,	2,	
etc.		

ByLayer	 Inside	of	plot	
poly	line	

Color	to	be	kept	blue	if	
existing	structure	is	to	be	
retained	

242	 ByLayer	 Color	to	be	changed	as	
242	if	existing	structure	is	
to	be	demolished	
Default	color	of	this	layer	
is	“Blue”	

14	 _Elevation		 140	 ELEVATION	 ByLayer	 Inside	of	
building	
polyline	

Text	should	be	kept	on	
same	layer	and	color.		

15	 _Floor		 153	 GROUND	
FLOOR	PLAN,	
FIRST	FLOOR	
PLAN,	Typical-
1,3,5	FLOOR	
PLAN,	Etc.		

ByLayer		
	

Inside	of	
building	
Polyline		
	

Floor	name	must	be	
matched	with	its	section	
on	sectionfloor	layer.		

16	 _FSISurrenderToCorp
o	

136	 NA	 ByLayer		
	

Inside	of	floor	
Polyline	

No	need	provide	text	on	
this	layer.	

17	 _GroundLevel	 63	 GL	 ByLayer	 Inside	of	
Section	
polyline	

Text	should	be	kept	on	
same	layer	and	color.		

18	 _IndFSI	 163	 NA	 ByLayer		
	

Inside	of	Floor	
Polyline		

No	need	of	text	for	this	
layer.		

200	 NA	 ByLayer	 Color	should	be	200	if	it	
is	existing	area	
Default	color	of	this	layer	
is	“163”	

19	 _IntRoad	 Green	 6.0m	Wide	
Int.	Road		

ByLayer		 Inside	of		Plot	
Polyline		

Need	to	mention	road	
width	in	its	text.	

20	 _Lift	 171	 LIFT	 ByLayer		 Inside	of	Floor	
/FSI	/	Parking	
/	Terrace	
Polyline		

Text	should	be	kept	on	
same	layer	and	color.		

21	 _LocationPlan		
	

211	 LOCATION	
PLAN		

ByLayer		 Outside	of	
building	and	
plot	

Text	should	be	kept	on	
same	layer	and	color.		

22	 _Marginline	 253	 NA	 ByLayer	 Inside	of	
Overlapped	
with	Plot	

No	need	of	text	for	this	
layer.		

23	 _MainRoad	 20	 12.0	M	Wide	
Main	Road		

ByLayer		 Outside	
overlapped	
with	Plot	

Text	should	be	start	with	
its	width.		

24	 _Nala	 65	 NALA	 ByLayer	 Overlap/insid
e	with	Plot	

Text	should	be	provided	
on	same	layer.	

25	 _NetPlot	 145	 NA	 ByLayer		 Inside	
Overlapped	
with	Plot	

No	need	of	text	for	this	
layer.		

26	 _OpenSpace	 Yellow		 LANDSCAPPED	
AREA			

ByLayer		 Inside	of	Plot	
Polyline		

Text	should	be	provided	
on	same	layer.	

27	 _Parking		 60	 Parking		 ByLayer		 Inside	of	Floor	
&	Plot	Polyline		

If	parking/Stilt	floor	is	
present.		

60	 CP	 ByLayer	 Individual	parking	is	
proposed	then	need	to	
draw	rectangle	by	its	size	

60	 SC	 ByLayer	



which	mentioned	in	
byelaws.	

28	 _Passage	 243	 PASSAGE	 ByLayer	 Inside	of	
Floor/	FSI	

Text	should	be	provided	
on	same	layer.	

29	 _Plot	 White		 PLOT	 ByLayer	 Outside	of	the	
building	
polyline		

Plot	should	be	outside	
overlap	with	MainRoad.	
Text	should	be	provided	
on	same	layer.	

30	 _Podium	 40	 PODIUM	 ByLayer	 Inside	of	
Plot/Floor	
Polyline		

Text	should	be	provided	
on	same	layer.	

31	 _PropWork	 Red	 A-1	
(BUILDING)		

ByLayer	 Inside	of	Plot	
Polyline		

Text	must	be	matched	
with	building	layer’s	text		
If	building	poly	text	is	“A	
(BUILDING)”	then	its	
proposed	work	text	
should	be	“A-1	
(BUILDING)”	

32	 _RailLine	 71	 RAILLINE		 ByLayer		 Should	be	
intersected	
Plot		

Poly	line	should	be	drawn	
as	open	polyline	and	
provide	its	text	with	
intersecting	open	
polyline	on	same	layer	
and	color.	

33	 _Ramp	 135	 10.0	M	Long	
and	1.0	M	
High	Ramp		

ByLayer	 Inside	of	
Floor,	Plot	
Polyline		
	

Length	and	its	height	
must	be	mentioned	in	its	
text		

34	 _RefugeArea	 146	 REFUGE	AREA	 ByLayer	 Inside	of	Floor	
Polyline		

Text	should	be	provided	
on	same	layer.	

35	 _ResiFSI	 190	 NA		 ByLayer		 Inside	of	Floor	
Polyline		

No	need	of	text	for	this	
layer.		

200	 NA	 ByLayer	 Color	should	be	200	if	it	
is	existing	area.	
Default	color	of	this	layer	
is	“190”	

36	 _ResvArea	 62	 RESERVE	
AREA		

ByLayer		
	

Inside	of	Plot	
Polyline		

Text	should	be	provided	
on	same	layer.	

37	 _RoadWidening	 67	 ROAD	
WIDENING		

ByLayer		 Inside	of		Plot	
Polyline	&	
should	be	
overlapped	
with	
MainRoad		

Text	should	be	provided	
on	same	layer.	

38	 _Room	 200	 LIVING,	
KITCHEN,	BED	
ROOM,	etc.		
	

ByLayer	 Inside	of	Floor	
/	Carper	Area	
Polyline		

Text	should	be	provided	
on	same	layer.	

39	 _Section	 75	 SECTION	 ByLayer	 Inside	of	
Building	and	
Outside	Floor	
Polyline		

Text	should	be	provided	
on	same	layer.	

40	 _SectionFloor	 132	 GROUND	
FLOOR,	FIRST	
FLOOR,	Etc.		

Bylayer		
	

Inside	of	
Section/	
building	
Polyline		

Section	floor	name	must	
be	matched	with	its	floor	
plans.		

41	 _SitePlan	 50	 SITE	PLAN	 ByLayer	 Inside	of	
building	
Polyline		

Text	should	be	provided	
on	same	layer.	

42	 _SpecialUseFSI	 213	 NA	 ByLayer	 Inside	of	Floor	
Polyline		

Need	to	draw	Special	use	
FSI	polyline	for	other	
than	residential,	



commercial,	industrial	
building	like	school,	
hospital	etc.		
No	need	to	give	text	on	
this	layer		

200	 NA	 Color	should	be	200	if	it	
is	existing	area.	
Default	color	of	this	layer	
is	“213”	

43	 _StairCase	 120	 STAIR	CASE	or	
FAB/SPIRAL	
STAIR		
	

ByLayer	 Inside	of	Floor	
/	FSI/	Parking/	
Terrace	
Polyline		

Text	should	be	kept	on	
same	layer	and	color.	
Default	color	of	this	layer	
is	“120”	

120	 NA	 Inside	of	
staircase	close	
polyline	

Draw	all	treads	as	open	
poly	line.	

161	 Draw	intermediate	
landing	as	open	polyline	

231	 Draw	floor	landing	as	
open	polyline	

44	 _SubStructure	 93	 ELECTRIC	
ROOM	

ByLayer	 Inside	of	Floor	
Or	Plot	
Polyline		
	

All	these	ancillary	
structure	to	be	drawn	on	
“_SubStructure”	layer.	
Default	color	of	this	layer	
is	“32”.	

93	 TRANSFORME
R	

105	 WATCHMAN	
ROOM	

127	 SOCIETY	
OFFICE	ROOM	

123	 SERVANT	
QUARTER	

43	 SANITARY	
BLOCK	

91	 GARAGE	
175	 EFFLUENT	

TREATMENT	
PLANT	

122	 OUT	HOUSE	
141	 PUMP	ROOM	
82	 SEPTIC	

TANK/SOAK	
PIT	

176	 WASTE	
WATER	
TREATMENT	
PLANT	

45	 _Tank	 133	 (O/H)TANK(1)	
	

ByLayer		 Inside	of	
Floor,	Plot	&	
Section	
Polyline		
	

Over	head	Water	to	be	
drawn	on	floor	as	well	as	
in	section	and	both	
polylines	texts	should	be	
in	this	format.	

(U/G)TANK(1)	 Under	Ground	Water	to	
be	drawn	on	floor	as	well	
as	in	section	and	both	
polylines	texts	should	be	
in	this	format.		

46	 _Terrace	 30	 TERRACE	 ByLayer	 Inside	of	Floor	
Polyline		

Text	should	be	provided	
on	same	layer.	

47	 _Void	 111	 VOID	 ByLayer	 Inside	of	Floor	
/FSI/	Parking	/	
Terrace	
Polyline		
	

Text	should	be	provided	
on	same	layer.	



48	 _VShaft	 11	 SHAFT	 ByLayer	 Inside	of	Floor	
/FSI/	Parking	/	
Terrace	
Polyline		

Text	should	be	provided	
on	same	layer.	

49	 _WaterLine	 131	 WATER	LINE	 ByLayer	 Inside	of	plot	
poly	line	

Poly	line	should	be	drawn	
as	open	polyline	and	
provide	its	text	with	
intersecting	open	
polyline	on	same	layer	
and	color.		

50	 _Window	 115	 W1,	W2,	V1,	
V2,	etc.		

ByLayer	 Inside	of	Floor	
/FSI	/	
Substructure	
Polyline		

Need	to	provide	W1,	W2,	
V1,	V2,	text	to	calculate	
no	of	windows	and	its	
text	should	be	inside	
window	poly.		

51	 _AddPrintDetail	 223	 NA	 ByLayer	 NA	 Need	to	draw	additional	
entities	on	this	layer,	
structural	details,	rain	
water	harvesting	section,	
etc.	

52	 _BuildingUse	 White	 Residential,	
Commercial,	
etc.	

ByLayer	 NA	 Need	to	show	use	of	the	
building	in	text	format	on	
this	layer	

53	 _BuildingSubUse	 White	 Apartment,	
Non-
apartment,	
hotel,	etc.		

ByLayer	 NA	 Need	to	show	sub	use	of	
the	building	in	text	
format	on	this	layer	

54	 _SchemeName	 White	 S1,	S2,	etc.	 ByLayer	 NA	 Enter	scheme	name	in	
text	format	on	this	layer	

55	 _TDRArea	 White	 TDR	Area:	
100.0	sqm,	
etc.	

ByLayer	 NA	 Enter	scheme	name	in	
text	format	on	this	layer	

	 	 																																																							Table	1	

How	to	create	layers	manually	using	CAD	software	

User	can	prepare	drawing	in	any	Computer	aided	design	software	which	file	extension	would	be	

“.dwg”	by	using	this	document	few	steps	are	given	below.		

If	user	is	using	an	AutoCAD:		
Step	1:	Open	AutoCAD	on	your	desktop		

Step	2:	open	layer	dialog	to	create	layer	like	this	

	
Note:	In	above	dialog	selected	color	would	be	default	color	code	of	this	layer	

		 	 Once	create	layer	then	need	to	draw	in	drawing		



	
	

Step	3:	If	Color	need	to	change	any	entity	then	go	to	AutoCAD	tool	bar	and	select	color	
as	mentioned	in	below	screen.	

	

Step	4:	Type	required	text	by	referring	‘Text’	column	from	table	below,	Select	line	type	mentioned	in	
the	line	type	table	below.	Refer	remarks	column	to	avoid	pre-formatting	errors.	
	

Note:	All	entities	in	drawing	must	be	closed	poly	lines	except	ground	level,	water	and	drainage	line.	



Section 2 

Preparing	submission	drawing	using	standard	CAD	drawing	template	

Architect	can	download	‘Standard	CAD	drawing	template’	(Drawing	Template.dwg)	file	available	

on	 single	 window	 system.	 All	 the	 required	 layers	 will	 be	 available	 in	 this	 CAD	 drawing	 file.	

Architect	to	draw	all	the	drawing	objects	on	the	layers	already	available	in	this	drawing	file.	Once	

the	 objects	 are	drawn	on	 the	 respective	 layers,	 architect	 can	 refer	 table	1	 of	 this	 document	 to	

assign	text/color	to	the	objects.	



Section 3 

Drawing	pre-formatting	utility	(PreDCR)	

Overview	

AutoDCR	scrutiny	software	needs	preformatted	drawings	with	some	specifications.	PreDCR	is	a	

software	application	used	to	create	the	architectural	plan	as	per	AutoDCR	software	requirements.	

It	 helps	 in	 standardization	 of	 drawings	 and	 helps	 in	 reducing	 time	 required	 for	 preparing	

submission	 drawings.	 It	works	 under	 AutoCAD	 as	well	 as	 CAD	 independent	 environment	with	

additional	menu	&	toolbar.	

	
Using	PreDCR	commands	user	can	create	all	the	required	layers	in	one	click.	Once	all	the	layers	

are	 created	 in	 the	 drawing	 user	 can	 use	 CAD	 commands	 to	 draw	 entities	 on	 the	

corresponding	layers	with	the	help	of	PreDCR	software.	Short	commands	are	provided	to	activate	

any	layer	in	PreDCR.	PreDCR	also	helps	in	correcting	drafting	errors	in	the	drawing.	At	any	time	

user	 can	verify	 if	 the	 drawn	 entities	are	 properly	 closed	 or	 not,	if	 proper	 name	 text	 has	 been	

written	inside	all	closed	poly	or	not	etc.	PreDCR	will	highlight	all	the	failed	entities	if	any.	



	

	

Aims	&	objectives	

To	bring	uniformity	and	standardization	in	submission	drawing	format.	

To	create	error	free	drawing	by	auto-correction	of	drafting	errors.	

To	Increase	drafting	speed	and	efficiency	

To	reduce	drawing	data	redundancy.	

To	remove	dimensioning	and	area	calculation	requirements	from	submission	drawing	format	

and	auto-calculating	areas	in	AutoDCR	automatically.		

	

Salient	features	

Automatically	creating	required	layers	in	the	drawing	

	

	

Automatically	creating	and	inserting	entites	of	required	size	in	the	drawing:	User	can	define	size	



of	entity	and	insertion	point	in	the	the	drawing.PreDCR	will	create	and	insert	entity	in	the	

drawing	at	specified	location.	

	

Automatic	insertion	of	required	text	in	the	drawing.	

	

	

Drawing	cleaning,	refinements	of	poly	lines,	text	and	closed	entity	verification	will	be	done	by	

PreDCR	to	eliminate	drafting	errors.	



	

	

PreDCR	verify	and	will	highlight	failed	entities	in	verifications	with	detailed	explanation	and	

Auto-zooming.	

	

	

	



Benefits	of	PreDCR	

1)	Standardization	of	submission	drawings-Brings	uniformity	&	standardization	in	submission	

drawing	format.	This	software	will	correct	some	minor	drafting	errors	and	also	provide	list	of	

failed	entities	with	Auto-zooming	facility	so	that	user	can	easily	locate	the	failed	entities	in	the	

drawing.		

2)	Operational	ease	and	convenience-Data	redundancy	is	eliminated	from	the	drawing.	Only	

minimum	required	entities	are	to	be	drawn	in	the	drawing	as	most	of	the	data	will	be	auto	

detected	by	the	system	from	existing	available	data.	

3)	Increased	speed	and	efficiency-PreDCR	facilitates	Auto	insertion	of	many	drawing	entities	like	

parking,	door	windows	etc	of	required	size	and	number.	Test	auto-insertion	facility	saves	text	

typing	efforts.	Auto-dimensioning	and	auto-calculation	facility	saves	calculation	efforts.	Using	

this	software	user	can	create	all	the	required	layers	at	one	click.				

4)	Accuracy	-	Accuracy	in	area	calculations	is	achieved.	Preparing	Calculation	tables,	showing	

dimensions	in	the	drawing	is	not	required.		

	

Drawing	formats	

1)	Conventional	submission	drawing	format		

	

	

2)	As	per	PreDCR	format	specified	by	PreDCR		

Conventional	drawing	submission	format	



	

	

3)	After	scrutiny	of	drawing	using	AutoDCR-	

	

	

Protocol	details	

PreDCR	is	a	software	application	used	to	create	the	architectural	plan	as	per	AutoDCR	software	

requirements.	It	works	under	AutoCAD	as	well	as	CAD	independent	environment	with	additional	

menu	&	toolbar.	

											Using	PreDCR	commands	user	can	create	all	the	project	wise	required	layers	in	one	click.	

Once	all	the	layers	are	created	in	the	drawing	user	can	use	AutoCAD	commands	to	draw	layout	

plan.	



As	per	AutoDCR	requirement	all	building	items	like	plot,	proposed	work	should	be	drawn	on	the	

corresponding	layers.	Short	commands	are	provided	to	activate	any	layer	in	PreDCR		

At	any	time	user	can	verify	if	the	drawn	entities	are	properly	closed	or	not,	if	proper	name	text	

has	been	written	inside	all	closed	poly	or	not	etc.	PreDCR	will	highlight	all	the	failed	entities	if	

any.	

										PreDCR	can	be	used	to	modify/make	and	verify	the	existing	or	new	architectural	plan	as	per	

AutoDCR	software	requirements.	Users	are	free	to	use	AutoCAD	commands	and	or	PreDCR	

commands	to	achieve	the	main	purpose	which	is:	
Drawing the architectural plan in DWG format as per AutoDCR software requirements.	
For	automating	the	process	of	Development	Control	Regulations	user/draughtsman/architect	have	

to	follow	some	specifications.	The	following	are	the	list	of	specifications	that	the	user	should	

follow.	Plot	layout,	detailed	floor	plan	and	building	section	for	all	the	floors	should	be	there	in	

one	AutoCAD	drawing	file.			

All	building	items	like	proposed	plot,	proposed	work,	proposed	parking	etc must	be	drawn	using	

closed	polyline.	

(i.e.	Every	entity	must	be	closed	LWPOLYLINE	except	Railway	Line	,	Drain	line,	Water	Line,	

Electric	Line,	DeadWall	and	Ground	lvl.).		

Building	Sub-Items	must	be	exactly	inside	of	outer	closed	polygon	as	per	their	place	

in	architectural	plan.	

This	means	none	of	the	edge	or	vertex	of	inside	entity	should	be	drawn	outside	its	container	

entity.		

							For	example	Parking	or	Open	Space	poly	must	be	exactly	inside	the	main	plot	poly.	

							Tools	are	provided	in	PreDCR	to	verify	this	check.		
Every Building Sub-Items should be given a specific/unique name (Text or MText entity) on the same 

layer & inside the entity poly.	If	name	not	found	then	AutoDCR	will	generate	the	name	

automatically.	Naming	Conventions	should	be	followed	properly.	

e.g.		Each	Room	should	be	given	the	concerned	name	Using	<Assign	Name>	function	of	preDCR	

Living,	Kitchen,	Bedroom..Etc.		

Floor	Name:	GROUND	FLOOR;	TYPICAL	FLOOR	1,2	&	5-8;	TERRACE	FLOOR	

Floor	Items:	Room	Names	should	be	given	properly	without	using	abbreviations	so	the	software	

can	identify	perfect	entity.	This	can	be	done	by	Assign	name	facility	provided	by	the	software.	

User	shall	use	only	following	kind	of	entities	for	Building	Items:	-		

LWPOLYLINE	/	TEXT	/	MTEXT	

If	in	a	plan	two	proposed	work	are	mirrored	in	that	case	user	should	provide	two	separate	

building	plans	for	each	proposed	work.	



 

Installation	and	Registration	

System	Requirements	

•									Pentium IV or better (or compatible processor)	

•									4 GB RAM Minimum	

•									Windows 98/2000/XP (32bit)/Vista/Windows7 (32bit)	

•							USB Port	

Installation	

To	install	PreDCR	software	on	your	computer	please	follow	the	given	steps.		

Step 1:  Insert the supplied PreDCR CD in CD drive of the computer. 

Step 2:  Run the PreDCR installer by double clicking on file "PreDCR_Installer.exe"  

in the PreDCR CD. 

Step 3:  Follow the next steps in installer wizard to complete installation.  

 

After successful installation, a PreDCR shortcut will be placed on your computer desktop as  

shown below. 

 

Figure 1: PreDCR shortcut on desktop 

 

How to use PreDCR 



 

1. Option for CAD Package Independent PreDCR Environment: 

	
• Description:- 

This	is	a	special	feature	provided	in	this	latest	version	of	PreDCR.	Now	user	can	use	the	
PreDCR	without	any	CAD	package	installed	on	their	machines.	This	feature	provides	a	
CAD	environment	with	all	PreDCR	command	and	options	required.	Apart	from	PreDCR	
commands	some	basic	commands	are	also	available	for	users	for	drafting	purpose.	
	

• Steps:- 
o Open	the	PreDCR	software	by	clicking	on	PreDCR	icon	on	your	desktop.	Following	

dialog	will	appear.	

	
 

o If	you	want	to	use	AutoCAD	based	PreDCR	then	select	the	‘Use	AutoCAD	
Compatible	PreDCR’	option	and	select	the	required	AutoCAD	version	from	the	
list.	Click	on	OK	button	to	proceed.		



	
This	will	automatically	open	the	selected	AutoCAD	version	and	the	PreDCR	Menu	
and	Toolbar	will	get	added	in	the	AutoCAD	environment.	
 

o If	you	don’t	want	to	open	the	PreDCR	in	AutoCAD	and	want	to	use	the	CAD	
interface	of	PreDCR	then	select	the	‘Use	CAD	Package	Independent	PreDCR’	
option	from	the	dialog.	Click	on	OK	button	to	continue.	



	
	
This	will	open	a	CAD	interface	with	PreDCR	Menu	and	Toolbar.	Basic	CAD	
commands	are	also	available	in	this	environment	which	can	be	used	for	drafting	
purpose.	
 

	

2. Layer Mapping: 

	
• Description:- 

A	user	friendly	interface	is	provided	for	users	to	map	his	Architectural	layers	in	drawing	
with	the	standard	PreDCR	layers.	User	will	have	to	only	map	the	layers	in	the	dialog	and	
PreDCR	will	automatically	create	the	mapped	layer	entities	in	drawing	on	standard	



PreDCR	layers.	
	

• Limitations:- 
This	will	only	map	the	Architect’s	layers	to	PreDCR	layers.	This	will	not	modify	all	the	
entities	drawn	on	Architect’s	layer	as	per	PreDCR	requirements.	User	has	to	provide	those	
entities	in	the	PreDCR	required	format.	(i.e.	in	the	polyline	format)	
	

• Steps:-	
o Open	the	drawing	in	PreDCR	environment.	
o Click	on	the	‘Select	Project	Type’	button	to	select	the	type	of	proposal.		

	
	
One	dialog	will	appear.	
	

o Select	the	Type	of	Project	for	the	open	drawing.	Click	on	OK	button.	

	
	
o If	the	drawing	contains	Layers	other	than	PreDCR	layers,	then	PreDCR	will	prompt	

you	to	use	Layer	mapping	tool.	

	
	

o Click	on	Yes	button	if	you	want	to	map	your	layers	with	standard	PreDCR	layers.	



o After	Clicking	on	Yes	button,	one	dialog	will	appear.	PreDCR	will	automatically	map	
some	of	the	layer	names	with	standard	PreDCR	layer	names.		

	
o This	dialog	contains	the	list	of	Layers	other	than	PreDCR	layers	in	drawing.	



o User	can	select	the	corresponding	PreDCR	layer	for	his	custom	layers	in	the	combo	
list.	

	
	
o After	mapping	all	your	Architect	layers	with	standard	PreDCR	layers	click	on	OK	

button.	
	

o PreDCR	will	automatically	create	standard	PreDCR	layers	and	all	the	mapped	
custom	layer	entities	will	get	shifted	to	corresponding	PreDCR	layers	(which	are	
mapped	by	user).	

	
o User	can	see	the	all	the	project	specific	PreDCR	layers	by	using	the	‘Layer	List’	

button	on	PreDCR	toolbar.	

	



o After	mapping	done,	use	‘Refinement	of	Drawing’	button	on	PreDCR	toolbar	for	
clean	up	of	drawing.	

	
	
	

3. Verifying Failed Entities: 

	
• Description:- 

In	the	failed	list	dialog,	we	have	provided	on	button	to	view	the	list	of	all	failed	entities	
with	their	Entity	Reference.	This	button	will	invoke	another	dialog	which	will	contain	the	
list	of	all	failed	entities.	User	can	see	the	failed	entity	in	drawing	by	just	clicking	on	the	
particular	item	in	the	list.	User	can	make	the	changes	in	drawing	for	that	failed	entity	and	
can	again	verify	that	entity	using	this	‘Verify	Again’	option	provided	on	this	dialog.	The	
status	of	that	entity	will	change	accordingly.	In	this	way	user	can	modify	those	failed	
entities	one	by	one	and	at	the	same	time	can	check	its	status.	So	no	need	to	verify	the	
complete	drawing	or	layers	to	check	the	status	of	failed	entities	after	corrections.	
	

• Steps:-	
o After	completion	of	verification	failed	dialog	is	invoked	(if	any	fail	entity	found	in	

drawing).		

	
	

	



Methodology		

1)			Open	the	PreDCR	software	for	clicking	on	PreDCR	menu	on	your	desktop	&	select	the	Use	

CAD	Package	PreDCR	option	&	then	click	on	"OK"	button.	

	

	
	

2)		First	open	submission	drg	which	is	now	converting	in	PreDCR	format.	

	



		
3)		Save	as	your	drg	with	give	some	name.	

	

	
	

4)	Check	the	scale	by	using	Scale	command.	If	drg	is	not	in	1:	100	scale	then	covert	into	the	1:100	

scale.&	then	make	that	drg	in	matric	scale	if	it	is	in	other	than	meter.		

	

	



	
	

	

5)	Also	make	the	site	plan	in	1:100	scale.	

	
		

6)		By	using	Predcr	toolbar	first	select	the	Type	of	Project	that	is	"	Proposed	Development“	,	

“Land	Division”	or	“Plotting	Layout”		

a)	If	Plot	is	Already	sanctioned	&	user	have	to	take	permission	for	the	buildings	only	then	select	

“Proposed	Development.”	

b)	If	User	having	Proposal	is	Amalgamation	or	Subdivision	then	select	“Land	Division”	option	

from	the	list.	



c)	If	Proposal	having	a	Plotting	Layout	then	select	that	“Plotting	Layout”	option	from	the	list.	

	

	
7)		By	using	Predcr	toolbar	"Create	a	DCR	layer"	that	is	second	option	in	Predcr	toolbar.	

	

	 	

	
	

8)		Then	u	will	get	the	list	of	PreDCR	toolbar	,	then	just	click	on	"OK"	button.	Now	all	the	Layers	u	

will	get	in	Layer	Properties	managers.	



	
	

Now	Select	current	Layer	is	"_	Plot"	&	Draw	a	closed	polyline	on	this	layer.	Also	give	the	plot	

name	on	that	layer	only.	

	



	
	

Make	the	current	layer	'_Main	Road”	&	Draw	a	road	on	this	layer.	Give	the	Name	of	road	which		is	

starting	with	it's	width.	

	

	
	

Make	the	current	Layer	"	…….FSI"	as	per	your	project		having	that	use	you	can	select	that	use	of	

FSI.	e.g.	For	Residential	use	-	Select		"_ResiFSI"		poly,	For	Commercial	use	select	“CommFSI”	poly.	

&	Draw	a	area	key	plan	line	on	this	layer.	No	need	to	give	any	name	on	this	Layer	



	
	

Make	the	current	Layer	"_Carpet	Area"	and	draw	a	closed	poly	on	this	Layer	which	having	floor	

area	excluding	wall	area.	Also	give	the	name	on	this	Layer.	If	carpet	is	splitted	no	of	places	but	

having	only	one	tenement	then	use	the	Splitted	tenement	option	from	Predcr	Mark	menu	bar.	

	

	
	

	

Make	the	current	Layer	"_Room"	and	draw	a	closed	poly	on	this	layer.	If	room	having	rectangle	

shape	then	u	can	use	rectangle	also.	Assign	the	room	name	for	using	the	assigned	name	option	

from	Predcr	menu	bar.	

	



	
	

:	Insert	the	doors	&	windows	by	using	insert	option	from	Predcr	menubar.		

	

	
	

	
15)		Make	the	current	layer	"_Floor"	and	draw	a	boundary	outside	of	each	&	every	floor.	

		



	
	

16)		Make	the	current	layer	"_Tank"	and	draw	U/G	&	O/H	tank	in	plan	as	well	as	in	section	also.	

Assigned	this	tank	name	by	using	Assigned	name	option	from	Predcr	menubar.	

		

	
	

17)	Make	the	current	layer	"_Staircase"	and	draw	all	the	riser	on	this	layer	which	is	a	open		

polyline.	Also	draw	two	extra	line	on	this	layer	which	is	showing	a	floor	landing	and	intermediate	

landing.	Then	mark	this	landing	for	using	staircase	landing	option	from	Predcr	menu.	Also	mark	



the	staircase	which	having	type.	For	spiral	and	fabricated	staircase	no	need	to	draw	riser	&	

landing	marking.	

	

	
	

	18)		Make	the	current	layer	is	"_Ground	Level"	and	draw	a	open	polyline	on	this	layer	which	is	

place	below	the	plinth	level.	

	

	



	

Make	the	current	layer	is	"_Building"	and	draw	a	boundary	on	this	layer	which	is	having	a	group	

of	all	the	floors	with	section	

	

	
Make	the	current	layer	is	"_ProposedWork"	and	draw	a	total	coverage	on	this	layer.	Assigned	

this	proposed	work	by	using	"Predcr->Assigned	name	->	Building	&	proposed	work	from	Predcr	

menu.	

	

	
If	project	having	any	Substructure	then	draw	a	closed	polyline	on	"_Substructure"	layer.	Also	

mark	this	substructure	by	using	"	Predcr->	Mark->	Substructure	from	Predcr	menubar.	

	



	
	

If	project	having	any	Existing	structure	then	draw	a	closed	polyline	on	"_Exstructure"	layer.	Also	

mark	this	Exstructure	by	using	"	Predcr->	Mark->	Exstructure	from	Predcr	menubar.	

	

	
	

Mark	the	margins	by	using	Mark->	margin	from	Predcr	menubar	

	



	
	

After	converting	all	the	Layers	use	the	"Fix	poly"	option	from	Predcr	menubar.		

	

	

	
	

	
	

just	click	on	"OK"	

	
just	click	on	"OK"	

	



	
	

When	u	will	get	these	message	"Refinement	of	Polyline	is	done"	then	select	the	"Verify	Closed	

poly"	option	from	Predcr	menu.	

	

	
	

	

	

	

	

	
	

	
	

:		When	u	will	get	these	message	"Entities	on	Predcr	Layers	are	verified	and	found	o.k."	then	only	



u	can	submit	a	softcopy	of	your	drg	to	the	Corporation.	

	
	

	

	
	

	

	
	

27)			Also	check	the	"Objection	list"	which	user	are	missing	to	convert	in	Predcr	layer.	

	

	
	

	
	

	



PreDCR Layer Information 
	

_Amalgamation	layer:	

	

Description	:	

	-	Draw	a	continuous	poly	around	the	plots	you	want	to			amalgamate.	
					Amalgamation	contains	more	than	one	plot	amalgamated				together.	

						All	entities	having	amalgamation	as	their	container	entity	should	be	uniquely	present	in	each	

amalgamation.	

i.e.	suppose	there	is	a	road	widening	in	the	Plot	then	the	poly	of	road	widening	should	be	

different	for	each	amalgamation.	(For	amalgamation,	draw	plot	1,	plot	2,plot	3	on	plot	layer	and	

amalgamated	plot	AmalPlot	1,	on	amalgamation	layer	overlapping	plot		

Verification	:	

	It	Should	overlap	with	_MainPlot/plot.	

Shortcut	Command	:	

	-	AMLG	

How	to	draw	:	

	

	

	
	

_Amenity		

	



Description	:	

	-	Draw	Amenity	space	as	a	closed	polyline	which	is	reserve	for	utilities,	services	and	

conveniences.	

Shortcut	Command	:	

	-	AMN	

How	to	draw	:	

	

	
	

	

	_ArchProj	

Description	:		

- This layer is used to represent various Architectural Projections in your Plan. Draw a closed Polyline 

for Architectural Projections. And mark it using Mark->Projection from PreDCR menu, according to 

requirements. Canopy/porch will come in plot & other projections will come with floor plans. 

Shortcut	Command:	

 - AP. 

How	to	draw	:	- 



																																					 	
	

_VentiShaft	

Description	:		

- Draw ArtiVentilation shaft/duct area as a closed Polyline with Text. Inside FSIArea on 

_ArtiVentiShaft Layer. Only those shafts from which ventilation for habitable room is not taken should 

be drawn on this layer. 

Shortcut	Command:	

 - AVS. 

How	to	draw	:	- 

                                     

.	_Balcony	

Description	:		



- Draw a balcony as a closed polyline which is a horizontal projection including parapet to serve as a 

sitting out place. Name of balcony must be inside and on _Balcony layer. 

Balcony can be present in :  

Plot: It must overlap with PWork (if not enclosed) 

Floor: It must overlap ResiFSI. 

Shortcut	Command	:		

- BL 

How	to	draw	:	-																																	

                  

_BasementLine	

Description	:		

- Draw a open polyline on this layer to represent various water bodies. 

Shortcut	Command	:		

- .BAS  

                               

	_Building	

Description	:	



 - Building is used to group all floor plans of the same building.   Draw a closed poly enclosing all the 

floor plans and section of the same building on _Building layer. Note: As written above, dimension or 

area of this building poly has no meaning in AutoDCR. This is just an logical group of all floors of the 

same building.If the building plan of multiple PWorks or wings are same then building name shall be 

as given in table below. 

Building names can be. 

1  "A(Monarch)" PWork "A" has building plan 

"Monarch". 

2  "A,B(Monarch)" or "A&B(Monarch)" Wings A, B have same building 

plan "Monarch". 

3  "A-C(Monarch)" Wings A,B,C have same 

building plan "Monarch". 

4  "A1-A3(Monarch)" Wings A1,A2,A3 have same 

building plan "Monarch". 

Shortcut	Command	:	

 - BLD 

How	to	draw	:	

 - What Building poly will have? Building poly will enclose all the floor plans in that building along. 

                          

    



 _CarpetArea	

Description	:		

- Draw carpet area as a closed polyline which is a net usable floor area within a building excluding that 

covered by the walls or any other areas specifically exempted from floor space index computation in 

these regulation. 

Shortcut	command	:	

 - CPT. 

How	to	draw	:	-	

                                          

	_Chowk	

Description	:		

- Draw a chowk as a closed polyline which is an enclosed space permanantly open to the sky within a 

building at any level. From chowk we take ventilation for habitual rooms. 

Shortcut	Command	:	

- CWK. 

How	to	draw	:	



                                             

_Column	

Description	:		

-Column shall be drawn as closed polyline on this layer. 

Shortcut	Command	:		

- .COL 

_CommFSI	

Description:	Commercial	FSI	:		

-  Draw a CommFSI as a closed polyline which is the area covered by a building on all the floors. This 

FSI polyline mainly used for commercial use bldg. 

Shortcut	Command	:	

 - CMFS.    How to draw : -                

                                                 

	_CompoundWall	



Description	:		

- Open polyline of compound wall to be drawn on proposed compound wall with text started with 

compound wall height. E.g. 1.5m. high Compound Wall 

Shortcut	Command	:	

 - CW. 

How	to	draw	:	-		

                                              

 

			_DisputedArea	

Description	:		

- Draw a closed poly around the disputed area if any in your proposal. Eg: Encroachments or area 

which are not in your possession can be drawn on this layer. 

Shortcut	Command	:	

 - .DA 

 



 

_DPRoad	

Description	:		

- Draw existing or proposed D. P. (Development Plan) road or T. P. (Town Planning) Road when 

inside/intersected with plot. While giving name start text with road -width. 

E.g. 15m wide D.P. Road. 

Shortcut	Command	:	

 - R3. 

How	to	draw	:	-	

 

 

                                         



_DrainLine	

Description:	-		

-  Drain Line shall be drawn as a open polyline on this layer. 

Shortcut	Command	:		

- L5. 

How	to	draw	:	-		

 

 

_Door	

Description	:		

- Door is a closed Polyline Which is drawn on “_Door” layer. Also you can insert a particular size poly 

for Door using Insert->Door from PreDCR menu. 

Shortcut	Command	:		

- DR. 

How	to	draw	:	-	



                                                

	_ElecLine	

Description	:	-	

 Electric line will be present in the layout plan and shall pass through plot entity as a non closed 

polyline. 

Name electric line shall start with its voltage capacity and text insertion point shall lie on its polyline. 

  For e.g. 33 KV High Tension Line 

Shortcut	Command	:		

- L1. 

How	to	draw	:	-	

                                          

	_Elevetion		

Description	:		

- Draw a elevation as a closed polyline which is a only outer line elevation  for printing  



_ExStructure	

Description : - Draw a Exstructure as a closed polyline which is a building or structure existing 

authorized before the commencement of these regulation. And mark it using Mark -> Existing 

structure as 'To be demolished' or 'To be retained’. 

Shortcut	Command	:		

- EX. 

How	to	draw	:-	

                                             

 

_ExistRoad	

Description: - Draw existing or proposed D. P. (Development Plan) road or T. P. (Town Planning) 

Road when inside/intersected with plot. While giving name start text with road -width. 

eg. 15m wide Road. 

Shortcut Command : - R3. 

How to draw : - 

 



 

_FSISurrenderToCorpo	

Description	:		

In case of accomodation reservation, the plot area or FSI to be surrendered to Authoriy is to be drawn 

on this layer. With text inside it. 

Shortcut	Command	:		

- STC. 

How	to	draw	:	-	

 

	_Floor	

Discription:	

Draw a Floor as a closed polyline to the boundary of the lower surface in a story on which one 

normally walk in a building and including mezzanine floor also. The floor at ground level with a direct 

access to a street or open space shall be called the ground floor, the floor above it shall be termed as 



Floor 1 with the next higher floor being termed as Floor 2 and so on upward. For giving the name of 

each floor use the assign named option from the PreDCR menu. Also draw each floor separately. 

While giving name to the typical floor then use a Typical option from Assigned name -> Floor name 

option from PreDCR menu bar. 

Shortcut	Command	:		

- FLR 

Reference Circle : - All Floor poly must contain a circle with its center on common point for whole 

building on layer "_ResiFSI". Usually it can be placed inside either Common Lift or stair/Inner Chowk 

as their locations are common for all floors. 

Floor Name : - Floor name will be taken from text inside floor poly and on same layer. 

  A floor plan is automatically associated/linked by AutoDCR software with one or more floor section 

poly in Section plan. This is done by matching name of Floor Plan and FloorInSection so both must be 

same. 

Typical Floor Non-Typical 

"TYPICAL" X "FLOOR PLAN"X: Floor numbers 

in specific format (, or & or -) 

X "FLOOR PLAN" 

X: Direct Floor's Name 

e.g.: 

TYPICAL 1,2 FLOOR PLAN 

TYPICAL 1-4 FLOOR PLAN 

TYPICAL 2&3 FLOOR PLAN 

e.g. 

GROUND FLOOR PLAN 

FIRST FLOOR PLAN 

SECOND FLOOR PLAN 

How	to	draw	:-	



                                     

	_GroundLevel	

Description	:		

- Draw the Ground level line as open polyline in section .It is used for checking a total building height 

from this line. 

Shortcut	Command	:		

- GL. 

How	to	draw	:	-	

                                              

_IndFSI	

Description	:		

- Draw a IndFSI as a closed polyline ( area key plan line in the submission drg) which is the area 

covered by all the floors. Indusrial building means building or part thereof wherein products or 

material are fabricated , assembled or processed such as assembly plants, laboratories , power plans, 



refineries, gas plants, mills, dairies and factories. This polyline should be excluding balcony & terraces 

area. 

Shortcut	Command	:		

- IFSI. 

How	to	draw	:	-	

                                          

                                              

_InternalRoad	

Description	:		

- Draw internal road with text specifying its width as shown in figure. And draw a center line. And 

type of layer of the center line must be center line (Type of the Layer). 

Shortcut	Command	:		

- R2. 

How	to	draw	:	-	



                                        

	_Lift	

Description	:		

- Draw a Lift as a closed polyline which is a mechanically guided car, platform or transport for persons 

and materials between two or more levels in a vertical or substantially vertical direction. If fire lift are 

provided then use the marking of “Fire lift" option from Mark -> Lift -> Fire Lift . Fire Lift means a 

special lift designed for the use of fire service personnel in the event of fire or other emergency. 

Shortcut	Command	:		

- LFT. 

How	to	draw	:		

                                                   

_LocationPlan	

Description	:		



- Location plan if any to be drawn on this layer. This is only for reference. No verifications are done by 

AutoDCR for this layer so not compulsory. 

Shortcut	Command	:		

- LCP. 

 _MainRoad	

Description	:	

 - Draw a MainRoad as a closed polyline which is abutting the plot. On the site that road is any type of 

road.such as any highway, street , lane, etc. over which the public have a right of passage or access or 

have passed and had access uninterruptedly for a specified period, whether existing or proposed in any 

scheme. Road name start with its width only. 

Shortcut	Command	:		

- R1 

How	to	draw	:	-	

 

 

                                                 

	_MarginLine	

Description	:		



- No need to draw Margin Line, Just use Mark Margin tool for it. This layer is not provided for users. 

AutoDCR uses '_MarginLine' layer for it's own internal use. 

	_Nala	

Description	:		

 Draw Nala polygon on this layer. 

Shortcut	Command	:		

- R4. 

How	to	draw	:	-	

 

  

	_NETPLOT	

Description	:		

- No need to draw NETPLOT. This layer is not provided for users. AutoDCR uses '_NETPLOT ' layer 

for its own internal use. 

 

_OpenSpace	

Description	:		

 Draw Open space as closed polyline reserved as recreational space on this layer. With text on same 

layer. 

Shortcut	Command:		



- OPS. 

How	to	draw	:	-	

 

_Parking	

Description	:		

- Draw a parking poly as a closed polyline which is an enclosed covered or open area sufficient in size 

to park vehicles. This closed polyline shall contain a text on same _Parking layer. This text is treated 

as name of parking. Insert the parking by using a Insert-> Parking option. 

Shortcut	Command	:		

- PK. 

Parking	Name	:	

 - This closed polyline shall contain a text on same _Parking layer. This text is treated as name of 

parking. 

  On this layer, you can group and insert any number of parking 

Parking Name 



Car Large CP-L 

Car Small CP-S 

Scooter SC 

Cycle CY 

Transportation vehicle TV 

Visitor's Parking ( Car ) VP 

Ambulance AMB 

How	to	draw	:	-	

 

_Passage	

Description	:		

- A closed polyline on _Passage represents a passage. It is a common passage or circulation space 

including a common entrance hall. This closed polyline contain a text. This text must be on "_Passage" 

layer. This text is treated as name of closed polyline. 

Centre Line :  

- All Passage poly must contain an Open Polyline inside that closed poly representing centre  line on 

"_Passage" Layer. But line type of center line must be 'Center line'. 

Shortcut	Command	:		

- PAS 

How to draw : - 



 

 

_ProAccessRoad	

Description	:		

- Draw ProAccessRoad as a closed polyline with text specifying its width.eg.1.5 m. wide pathway. 

Shortcut	Command:		

R8 

How	to	draw	:-	

 

_Plot	

Description:	



 - Draw a Plot poly as a closed polyline which is a parcel or piece of land enclosed by definite 

boundaries. A Plot will contain all Proposed Works (buildings, wings), open space, Internal Roads, 

Parking etc. The overall Plot Entity represent a Plan, AutoDCR refers it as 'Layout Plan'. The overall 

Plot Entity represent a Plan, AutoDCR refer it as "Layout Plan". 

Shortcut	Command:		

PLT 

How	to	draw	:-	

 

_Podium	

Description	:		

- Podium shall be drawn on '_Podium' layer as a closed polyline. Podium should be inside plot 

covering proposed works if any. 

Shortcut	Command:		

POD. 

How	to	draw	:-	



 

 

_PropWork	

Description	:		

- Proposed Work is a building profile/outline and shall be drawn inside plot. all detail Building plans 

(inside building polyline ) of all PWork( inside plot polyline) is associated/linked automatically by 

Auto-DCR by matching its name. 

  So for proper association it is required to follow specific standard as given. 

  XY (Z) 

  X is Wing name. 

  Y is wing number. 

  Z is Building name. 

For example if there are four wings A1,A2 & B1,B2 in building named "Monarch" then proposed 

work  names shall be - 

  A1 (Monarch), A2 (Monarch) 

  B1 (Monarch), B2 (Monarch) 

Reference Circle: All PWork poly must contain two circles (of any size) with its center on common 

point for whole building. First on layer of any FSI and second on Layer “_Floor”. These reference 

circles to be inserted from PreDCR -> insert-->Direction ref circles at the same location in all the 

floors as well as pwork in plot.  Usually they can be placed inside either Common Lift or Stair/Inner 



Chowk (because generally their location is same on all floors). Reference circles are used by the 

software for overlapping all floor plans. 

Shortcut	Command:	

 PW. 

How	to	draw	:-	

 

	

_RailLine	

Description	:		

- Railway line shall be drawn as a non closed polyline with some text indicating gauge of rail line over 

it. 

Shortcut	Command	:		

- L2. 

How	to	draw	:	-	



 

	

_Ramp	

Description	:		

- Draw a Ramp poly as a closed polyline in floor plans and/or plot and section. Naming convention for 

ramp is "---m. long and ---m. high ramp-1". give unique name to each ramp. 

Shortcut	Command	:		

- RP. 

How	to	draw	:	-	

 

	

_RefugeArea	

Description	:		

- Refuse area to be drawn in plan as a closed polyline with text on this layer. Overlapped with FSI 

layer but outside the FSI poly. 

Shortcut	Command	:		



- RFG. 

How	to	draw	:		

 

_ReservArea	

Description	:		

- Reserved area ( Reservation area in Development plan) shall be drawn on this layer if present in 

proposal. This can be any area reserved for/by Authority for future. 

Shortcut	Command	:	

- RSA. 

How	to	draw	:-	

 

 

_ResiFSI	



Description	:		

- Draw a ResiFSI as a closed polyline which is the area covered by a building on all the floors. This 

FSI polyline only used for residential use building or floor. ResiFSI poly must be inside Floor poly. 

Shortcut	Command	:	

 - MFS 

How	to	draw	:	-	

 

	

_RoadWidening	

Description	:		

- Draw a road widening polyline as a closed polyline which the plot area is going to the road, that area 

should be drawn on this layer. It should be inside the plot polyline. 

Shortcut	Command	:	

 - R5. 

How	to	draw	:	-	



 

_Room	

Description	:		

- A closed polyline on _Room layer represents a room. This closed polyline contain a text. This text 

must be on _Room layer. Room to be marked by assigning them names using Assign Name-> room 

option from PreDCR menu. 

Shortcut	Command	:		

- RU. 

How	to	draw	:	-	

 

	

_Sanitation	

Description	:		



 Draw any sanitation entities on this layer. (E.g. Water closet , Kitchen sink etc..) Mark those entities 

by using PreDCR -> Insert -> Sanitation. 

Shortcut	Command	:		

- SND. 

_Section	

Description	:		

- Draw a Section polyline as a closed poly of section boundary which contain all floors with stair 

cabin, Lift machine room, water tanks etc. as shown in the figure. Also write the name as "Section" in 

this section poly. 

In this closed poly of section draw sections of all floors with stair cabin, inner Chowk, Lift machine 

room, Ventilation shaft, water tanks etc. as shown in the figure. 

Also write the name as "Section" in this section poly. 

This section poly will present inside the building poly. 

Shortcut	Command	:		

- SEC. 

How	to	draw	:	-	

 

 

_SitePlan	



Description : - Site plan if any to be drawn on this layer. This is only for reference. No verifications 

are done by AutoDCR for this layer. so not compulsory. 

Shortcut Command : - STP 

 

_SpecialUseFSI	

Description : - FSI ploy for all other building uses like educational, institutional etc. except ResiFSI, 

CommFSI &  IndFSI use should be drawn on this layer. 

Shortcut Command: - SUF. 

How to draw: - 

 

 

	_StairCase	

Description	:		

- StairCase: On this layer, Each StairCase poly shall have three lines for Flight Width, Intermediate 

Landing and Floor Landing on same layer. Mark these open polyline by using Mark-> Staircase 

option from PreDCR menu. Also draw in plan all the treads on this layer which is a open polyline. 

This closed polyline contains a text. This text must be on _Stair layer. This text is treated as name of 

closed polyline. On this layer, Each StairCase poly shall have three lines for Flight Width, 

Intermediate Landing and Floor Landing on same layer This can be mark by tool Mark > StairCase > 

intermediate landing etc. 



Shortcut	Command	:		

- STR. 

How	to	draw	:	-	

 

_StepFirst	

Description:		

- Draw a closed poly which will represent the StepFirst in case of a combination of Amalgamation and 

Subdivision process. It represents the logical grouping of all entities to be treated as the 1st step in case 

of a combination. .eg: if 4 plots are to be amalgamated to get 1 plot and then that 1 plot is further 

divided to get 3 plots then the sketch with _Plot and _Amalgamation will be bounded by StepFirst poly 

of any shape and the sketch with _Plot and _Subdivision will be bounded to by StepSecond poly. 

Shortcut	Command:	

 SF.  

 

 



	

_StepSecond	

Description:	

 - StepSecond is used to group all amalgamations or subdivisions.Draw a closed poly enclosing all 

amalgamations or subdivisions.This layer is used only when you have combination case such as 

'Amalgamation+SubDivision'(i.e. A+S) or SubDivision+Amalgamation'(i.e. S+A).If you are going for 

'A+S' case then always draw _SubDivision poly inside _StepSecond poly.And If you are going for 

'S+A' case then always draw _Amalgamation poly inside _StepSecond poly. 

Shortcut	Command:		

SS.  

How	to	draw:		

 

_SubPlot(RowHouse)	

Description	:		

- A SubPlot in Layout should be drawn on this layer. 

Shortcut Command : - .SP 

 

_ SubDivision	

Description	:	

	- In	Subdivision	one	plot		is	divided	into	more	than	one	Subdivisions.	

All	entities	having	subdivision	as	their	container	entity	should	be	uniquely	present	in	all	



Subdivisions	of	a	Plot	i.e.	suppose	there	is	a	road	widening	in	the	Plot	then	the	poly	of	road	

widening	should	be	different	for	each	Subdivision(	subdivided	plot).	

Ex.	Here	Plot	1	is	divided	into	three	Subdivisions.	And	also	the	Road	Widening	is	divided	into	

RoadW	1	and	RoadW	2	for	each	Subdivision.		

     (for subdivision, draw plot 1 on plot layer and subdivided plots like SubDiv 1,SubDiv 2 &              

SubDiv 3 on sub-division layer overlapping plot 1.) 

Shortcut	Command	:		

- SBD 

How	to	draw	:	-	

 

                                

	

_SubStructure	

Description	:		

- Draw various substructures on "_SubStructure" layer as a closed polyline. And mark it according to 

the requirement as Mark -> Substructure -> Society Office, from PreDCR menu. Sub-structures can 

be drawn inside plot or in floor plans. 

Shortcut	Command	:		

- SSTR. 

How	to	draw	:	-	



 

	

_Tank	

Description	:		

- A closed polyline on _Tank layer represents a water tank. Under Ground tank can be drawn in Floor 

or Layout plan. If it is drawn in Floor plan then it should be at bottom of GROUND FLOOR. 

Overhead tank can be drawn in TERRACE FLOOR. Tank should be drawn as per internal size or 

dimensions. Both the tank also draw in section also. 

Tank Name: - This closed polyline contain a text and must be in given format. This can also be done 

by tool Assign Name>Tank 

  Tank Name+ Type +Capacity 

Tank Type Text 

Overhead water tank (O/H) 

Underground water 

tank 

(U/G) 

  For e.g. 

  TANK-1 (O/H) 

  TANK-2 (U/G) 

Under Ground tank can be drawn in Floor or Layout plan. If it is drawn in Floor plan then it should be 

at bottom of GROUND FLOOR. 



Overhead tank can be drawn in TERRACE FLOOR. Usually it is drawn on StairCase poly in 

TERRACE FLOOR. 

Shortcut	Command	:		

- TNK. 

How	to	draw	:	-	

 

	

_Terrace	

Description:		

- Draw a Terrace as a closed polyline on _Terrace layer which is including parapet wall. 

Terrace can be present in:  

 Plot: It must overlap with PWork 

 Floor: It must be outside the ResiFSI. 

Shortcut	Command	:		

- TER. 

How	to	draw	:	-	



 

 

	_Void 

Description	:	

 - If the space is not Chowk then it can be void. All ducts (where ventilation is not taken) and double 

height rooms can be drawn in void layer. 

Shortcut	Command	:		

- VD. 

How	to	draw	:	-	

 

	

	

_WaterLine	

Description	:		



- Draw a Water line as a open polyline to show Water supply. 

Shortcut	Command	:		

- WL. 

How	to	draw	:	-	

 

	

_Window	

Description	:		

- Window is a closed Polyline Which is drawn on "_Window" layer. Also you can insert a particular 

size poly for Window using Insert->Window from PreDCR menu. 

Shortcut	Command	:		

- WND. 

How	to	draw	:	-	



 

Tools  

All/Remover Tool Tip ( PDCRTOOLTIP ): 

This	command	will	activate	the	tool	tips	for	PreDCR	layers.	
 

Show Only DCR Layers:	

All PreDCR layers (PDCRSPL):	

This	command	will	turn	off	all	the	layers	in	the	drawing	except	PreDCR	layers	

Building level layer (PDCRSBL): 

	This	command	will	turn	on	all	the	building	plan	level	layers	in	the	drawing.	

	

Layout level layer (PDCRSLL): 

 

This	command	will	turn	on	all	the	Layout	plan	level	layers	in	the	drawing.	

	

Show Only DCR Layers (PDCRSDL): 

	

This	command	will	turn	off	all	the	layers	in	the	drawing	except	DCR	layers.		

		

Show Other Layers (PDCRSOL): 

	

This	command	will	turn	off	all	the	DCR	and	PreDCR	layers	in	the	drawing.	

	

Show All layers (PDCRSAL); 



	

	This	command	will	turn	on	all	layers	in	the	drawing.	

	

Calculate Total Area (PDCRCTA): 

	

This	command	will	compute	the	total	area	of	all	selected	closed	polygons.	

	

	

Calculate Deducted Area (PDCRCDA): 

	

This	command	will	compute	the	area	of	closed	polygon	after	deducting	closed	polygons	found	

inside.	

					 					 	

Get All Inside Poly (PDCRFIP):  

	

This	command	will	highlight	all	polygons,	which	found	exactly	inside	selected	polygon	under	test.	

		

Get All Overlapping Poly (PDCRGOP): 

	

This	command	will	highlight	all	polygons,	which	are	overlapping	with	selected	polygon	under	

test.	

		



Get All Intersecting Poly (PDCRGIP): 

	

This	command	will	highlight	all	polygons,	which	are	intersecting	with	selected	polygon	under	

test.	

		

Find Open Entities (PDCRFNDO):  

 

Highlight	open	entities	on	PreDCR	layers.	
 

Find Closed Entities (PDCRFNDC):  

 

Highlight closed entities on PreDCR layer.	

	

Shortest distance (PDCRFSD):  

	

This	command	will	find	the	shortest	distance	between	two	entities.	

	

Spelling	check	(_spell):		

	

This	tool	is	used	for	spelling	checking.	

	

Find	Object	(PDCRFOBJ):		

	

This	command	zoom	&	highlight	object	of	a	given	handle.	

	

Set	Default	ACAD	Version	(	PDCRSDA	):	

	

	

	

	



	

Commands 

Create	New	Project	(PDCRNWP):		

This command will Create New project for current drawing. 

Here you have to select Type of Project as  

 Proposed Development. 

 

Note: It is always compulsory to add your drawing to new Project. 

 

 

Create	AutoDCR	Layers	(PDCRCL):		

This command will create layers required for AutoDCR and as per the Project Type you have 

selected. 

Fix	Poly	(PDCRPE):		

	

Use	this	command	once	on	the	final	drawing	which	will	process	all	the	polyline	on	the	PreDCR	

layer	and	remove	extra	vertices	found	on	polyline.	This	command	can	be	used	before	verifying	

the	drawing	using	Verify	commands.	

	



	

	

Verify	Drawing:		

	

This	command	will	verify	the	current	drawing	as	required	by	DCR	specifications.	

	a)	Verify	Close	Entities	(PDCRVD):	Verify	that	LWPOLYLINE	entities	on	the	selected	layers	

are	closed	and	contain	one	text	.	

	
b)	Verify	All	drawing	(PDCRVT):	Use	this	command	to	verify	the	layout	and	building	level	

objects	in	the	current	drawing	plan.		

Major	checks	are	as	follows:	



	

	

	
In	the	"Verify	All	Drawing	Dialog"	you	can	select	the	layout	or	building	objects	to	be	checked.	

Then	to	view	the	result	press	OK	button.	PreDCR	will	start	checking	all	corresponding	objects	in	

the	currently	open	drawing	and	then	display	the	status	as	OK	or	list	of	failed	objects	in	the	

dialog	as	shown	in	Figure.	Failed	Object	Information.		

Check	if	these	entities	are	drawn	as	closed	LWPOLYLINE.	

Name	text	is	given	to	all	objects.	

Entities	are	placed	exactly	inside	their	parent	objects	(container).	

Naming	conventions	are	followed	properly.	

c)	Objection	List	(PDCROLST):	This	command	gives	the	list	of	all	minimum	required	entities	

which	are	not	there	in	your	drawing.	If	all	required	entities	found	then	it	gives	a	message	that	

“minimum	required	entities	are	present	in	drawing”.	

	

 Markings 
	

Marking	adds	some	extra	meaning	in	entity.	Following	commands	are	provided	to	mark	

different			entities	as	per	requirement.		

Mark->	Stair	Case->	Fab	/Spiral	Staircase	(PDCRSCFAB):	Mark	line	inside	staircase	as	a	

Fabricated	or	spiral	staircase.		

Mark->Stair	Case->	Taken	in		FSI				(PDCRSCES):	Mark	taken	in	fsi		



	

	

					Mark	Intermediate	Landing	(PDCRMIL):	Mark	line	inside	staircase	as	intermediate	

Landing.		

Mark->Stair	Case	Landing->Flight	Width	(PDCRMFW):	Mark	line	inside	staircase	as	Flight	

Width.	

Mark->Stair	Case	Landing->Floor	Landing	(PDCRMFL):	Mark	line	inside	staircase	as	Floor	

Landing.		

2)		Mark->	Lift->	(PDCRSCES):	mark	Lift	as	a		Free	From	FSI	OR	Taken	in	FSI	(Default)		

								Mark->Passage->	:	Mark	passage	as	a	taken	in	fsi	(default)		

	3					Mark->Open	space->	playground	or	normal	default	(PDCRPSUP):	playground	or	normal	

(default)	

						Mark->FSI->Road	Widening	(PDCRCONES):	Mark	Residential	or	Commercial	FSI	as	Road	

widening	areas	FSI.	

Mark->FSI->	TDR	(PDCRCONES):	Mark	Residential	or	Commercial	FSI	as	TDR.	

Mark->FSI->	free	fsi	basement	area	(PDCRCONES):	Mark	free	fsi	basement	area	

Mark->FSI->	Existing	FSI	(PDCRCONES):	Mark	Residential	or	Commercial	FSI	as	Existing	FSI.	

Mark->FSI->Normal	(Default)	(PDCRUMFSI):	Mark	Residential	or	Commercial	FSI	as	Normal	

FSI.	

Mark->Special	use	fsi	->	Sport	fsi	or	m9	fsi	(PDCRUMFSI):	Mark	Special	use	fsi	->	sport	fsi	or	

m9	fsi	

Mark->FSI	Surrender	to	Rajsthan->	Dispensary	(PDCRMSPLTT):	Mark.	Dispensary.	

						Mark->FSI	Surrender	to	Rajsthan	->	Maternity	Home	FSI	(PDCRMSPLTT):	mark->	maternity	

home	fsi	

						Mark->FSI	Surrender	to	Rajsthan	->	Hospital	(PDCRMSPLTT):	mark->	Hospital	

						Mark->FSI	Surrender	to	Rajsthan	->	Parking	Area	(PDCRMSPLTT):	mark->	parking	area	

Mark->Carpet	Area->Splitted	Tenement	(PDCRMSPLTT):	Mark	Carpet	Area	as	Splitted	

tenement.	

Mark->Carpet	Area->	Normal	(Default)	(PDCRUMFSI):	Mark	Residential	or	Commercial	Carpet	

Area	as	Normal	Carpet	Area.	

Mark->Terrace	->Common	or	Individual	(Default)	(PDCRMENCBL):	Mark->	Terrace	

Common	or	Individual	(default).	

Mark->Balcony->Enclosed	Balcony	(PDCRMENCBL):	Mark	Balcony	as	enclosed	balcony.	



	

	

Mark->Balcony->Unmark	(Default)	(PDCRUMENCBL):	Unmark	the	marked	balcony.	

Mark->Projection--	>	

Mark->Projection->Otta/Steps	(PDCRMVPROJ):	Mark	Projection	as	Garbage	shaft.	

Mark->Projection->F.Bed	(PDCRMBPROJ):	Mark	Projection	as	Flower	Bed.	

Mark->Projection->Chhajja/Cornice/Whether	shade	(PDCRMCJPROJ):	Mark	Projection	as	

Chhajja/Cornice/Whether	shade.	

Mark->Projection->Canopy	(PDCRMCBPROJ):	Mark	Projection	as	Canopy.	

Mark->Projection->Loft	(PDCRMLPROJ):	Mark	Projection	as	Loft	in	floor	plan	as	well	as	in	

section	.	

Mark->Projection->Porch	(PDCRMCPROJ):	Mark	Projection	as	Canopy.	

Mark->Projection->Archi.	Projection	Normal	(Default)	(PDCRUMPROJ):	Mark	Projection	as	

Normal	Architectural	projection.	

	

Mark->Main	Road->	Adjoining	Road	(PDCRMRVIFSI):	Mark->	Main	Road->Adjoining		Road	

					Mark->Main	Road->UnMark	(Default)	(PDCRUMMR):	Mark	->Main	Road-

>Unmark(Default)	

Mark->Existing	Structure	->To	Be	Retained		(PDCRMREXWD):	Mark	Existing	structure	as	to	

be	Retained	.	

Mark->Existing	Structure->	To	be	demolish	(Default)	(PDCRMRMREXWC):	Mark	Existing	

structure	as	to	be	Demolish.	

Mark->SubStructure->	Meter	Room	(PDCRMER):	Mark	Sub	Structure	as	a	meter	room.	

Mark->SubStructure->Transformer->	To	be	added	in	fsi			(PDCRMTRAN):	Mark	Sub	Structure	

as	an	Transformer->To	be	added	in	fsi.	

Mark->SubStructure->Transformer->Normal	(Default)			(PDCRMTRAN):	Mark	Sub	Structure	

as	a	Transformer->Normal	(Default)	

Mark->SubStructure->Watchman	cabin	(PDCRMWMC):	Mark	Sub	Structure	as	a	Watchman	

cabin.	

Mark->SubStructure->Society	Office	(PDCRMOR):	Mark	Sub	Structure	as	a	Society	office.	

Mark->SubStructure->Servant	Quarter	(PDCRMSQ):	Mark	Sub	Structure	as	a	servant	quarter.	

Mark->SubStructure->Sanitary	Block	(PDCRMSB):	Mark	Sub	Structure	as	a	sanitary	block.	

Mark->SubStructure	->	Garage	(PDCRMGRJ):	Mark	Sub	Structure	as	a		garage	when	garage	is	



	

	

covered.	

Mark->SubStructure	->Effluent	Treatment	Plant	(PDCRMETP):	Mark	Sub	Structure	as	a	

Effluent	Treatment	Plant.	

Mark->SubStructure	->Out	House	(PDCRMSPT):	Mark	Sub	Structure	as	a	Out	House.	

Mark->SubStructure	->Pump	House	(PDCRMPR):	Mark	Sub	Structure	as	a	Pump	House		

Mark->SubStructure	->Septik	Tank	/	Soak	pit	(PDCRMSPT):	Mark	Sub	Structure	as	a	Septik	

Tank.	

Mark->-	Zone->ABC->	Residential	(PDCRMER):	Mark->ABC->Residential	

Mark->-	Zone->ABC->	Commercial	(PDCRMER):	Mark->ABC->Commercial	

Mark->	Zone->ABC->	Industrial	(PDCRMER):	Mark->ABC->Industrial		

Mark->	Zone->ABC->	Green	Zone	/belt(PDCRME):	Mark->ABC->Green	zone/belt	

Mark->	Zone->ABC->	Hill	Top	Hill	slop	(PDCRMER):	Mark->ABC->	Hill	Top	Hill	slop	

Mark->	Zone->ABC->	Brick	kiln	(PDCRMER):	Mark->ABC->	Brick	kiln	

Mark->	Zone->ABC->	Public	semi	public	(PDCRMER):	Mark->ABC->	Public	public	semi	public			

Mark->	Zone->ABC->	Extg.	Cremation/burial	Ground	(PDCRMER):	Mark->ABC->	Extg.	

Cremation/burial	Ground	

Mark->	Zone->ABC->	Defence	(PDCRMER):	Mark->ABC->	Defence.	

Mark->	Zone->ABC->	Extg.Parking	(PDCRMER):	Mark->ABC->	Extg.	Parking	

Mark->	Zone->ABC->	Railway	(PDCRMER):	Mark->ABC->	Railway	

Mark->	Zone->	D->	Residential	(PDCRMER):	Mark->	D->	Residential	

Mark->	Zone->	D->	Commercial	(PDCRMER):	Mark->	D->	Commercial	

Mark->	Zone->D->	Industrial	(PDCRMER):	Mark->D->Industrial		

Mark->	Zone->D->	Green	belt(PDCRME):	Mark->D->Green	belt	

Mark->	Zone->D->	Low	water	availability	(PDCRME):	Mark->D->	Low	water	availability	

Mark->	Zone->D->	Public	semi	public	(PDCRMER):	Mark->D->	Public	semi	public			

Mark->	Zone->D->	Defence	(PDCRMER):	Mark->D->	Defence	

Mark->	Zone->D->	Town	planning	scheme	(PDCRMER):	Mark->D->	Town	planning	scheme	

Mark->	Zone->D->	Forest	(PDCRMER):	Mark->D->	Forest	

Mark->Margin	(PDCRMRGN):	Use	this	command	to	define	or	mark	the	front,	sides	and	rear	

margins	of	the	plot.	.	

	



	

	

	

 

Insert entities 
Insert->Parking->	Car	(	(PDCRICP)	->	Use	this	command	to	insert	car-parking	poly	of	.	at	

selected	point.		

Insert->	Parking->	Scooter	(PDCRISP)	->Use	this	command	to	insert	Scooter	parking	poly	at	

selected	point.	

Insert->	Parking->	Cycle	(PDCRICY)	->Use	this	command	to	insert	Cycle	parking	poly	at	

selected	point.	

Insert->Parking->	Loading	unloading			(PDCRITV)	->Use	this	command	to	insert		parking	

Loading	unloading			poly	at	selected	point.	

Insert->Parking->Visitors	Parking->Car	(PDCRIVP)	->	Use	this	command	to	insert	visitor	car	

parking	poly		at	selected	point	

	

Insert->Door	(PDCRIDRNAM):	Use	this	command	to	insert	door	poly	at	selected	point	and	with	

specified	size	given	by	user.	As	soon	as	you	use	this	command	the	following	Dialog	appears.			



	

	

										 	
Insert->Window	(PDCRIWNDNAM):	Use	this	command	to	insert	window	poly	at	selected	

point	and	with	specified	size	given	by	user.	

	
Insert->	Text	(PDCRIWC):	Use	this	command	to	insert	sanitation	text	at	selected	point.	Ex.		

Water	closet	,		Urinal	,	Wash	basin	etc……….	which	is	mark	on		then	insert	text	by	using	

sanitation	text	marking	from	insert	menu.	

Insert->Direction	Reference	Circle	(PDCRIWC):	Use	this	command	to	insert	direction	

reference	circle.	Insert	this	circles	in	all	the	floor	plans	as	well	as	in	proposed	work	at	the	same	

&	common	place	(e.g.	Lift	or	Stair)	of	all	the	floors.	

	

Insert	->	Tree:	Use	this	to	insert	Tree.	Insert	Trees	showing	location	of	Trees	in	your	plot.		

Insert->North	Direction:	Use	this	to	insert	North	Direction.	Insert	North	Direction	indicating	

the	sides	of	your	plot.	You	have	to	rotate	this	as	per	North	Side.		

 

 



	

	

Assign Name 
 
-	There	are	few	naming	conventions	required	by	AutoDCR,	for	which	PreDCR	provides	the	
following	tools:	

Assign	Name->Building	and	proposed	works	(PDCRBLDPWNL):	Use	this	command	to	give	

name	for	building	poly	and	its	associated	proposed	works.	

	
Assign	Name->Tank	(PDCRTNKNAM):	Use	this	command	to	give	name	for	Tank	poly	and	its	

corresponding	tanks.	

 

Fill	in	the	dialog	and	select	the	tank	poly	drawn	in	plan	and	the	same	drawn	in	section 

Assign	Name->Room	(PDCRASRUN):	Use	this	command	to	give	different	names	for	Room	poly.	



	

	

									 	
	

Assign	Name->Floor	Name		(PDCRASFLRNAM):	Use	this	command	for	assigning	name	to	a	

floor	poly	and	it’s	corresponding		floor	in	section	poly	in	section.	

	
	



	

	

Tools  
All/Remover Tool Tip (PDCRTOOLTIP): 
This command will activate the tool tips for PreDCR layers. 

Show Only DCR Layers:	
All PreDCR layers (PDCRSPL):	
This	command	will	turn	off	all	the	layers	in	the	drawing	except	PreDCR	layers.		
Building level layer (PDCRSBL):	
	This	command	will	turn	on	all	the	building	plan	level	layers	in	the	drawing.	

Layout level layer (PDCRSLL):This	command	will	turn	on	all	the	Layout	plan	level	layers	in	the	

drawing.	
Show Only DCR Layers (PDCRSDL):	
This	command	will	turn	off	all	the	layers	in	the	drawing	except	DCR	layers.		

		
Show Other Layers (PDCRSOL):	
This	command	will	turn	off	all	the	DCR	and	PreDCR	layers	in	the	drawing.	

	
Show all layers (PDCRSAL);	
	This	command	will	turn	on	all	layers	in	the	drawing.	

	
Calculate Total Area (PDCRCTA):	
This	command	will	compute	the	total	area	of	all	selected	closed	polygons.	

	
	
Calculate Deducted Area (PDCRCDA):	
This	command	will	compute	the	area	of	closed	polygon	after	deducting	closed	polygons	found	

inside.	



	

	

					 					 	
Get All Inside Poly (PDCRFIP): 	
This	command	will	highlight	all	polygons,	which	found	exactly	inside	selected	polygon	under	

test.	

		
Get All Overlapping Poly (PDCRGOP):	
This	command	will	highlight	all	polygons,	which	are	overlapping	with	selected	polygon	under	

test.	

		
Get All Intersecting Poly (PDCRGIP):	
This	command	will	highlight	all	polygons,	which	are	intersecting	with	selected	polygon	under	

test.	

		
Find Open Entities (PDCRFNDO): Highlight open entities on PreDCR layers. 

 

Find Closed Entities (PDCRFNDC): Highlight closed entities on PreDCR layer.	

	

Shortest distance (PDCRFSD): 	
This	command	will	find	the	shortest	distance	between	two	entities.	

	

Spelling	check	(_spell):	This	tool	is	used	for	spelling	checking.	

	

Find	Object	(PDCRFOBJ):	This	command	zoom	&	highlight	object	of	a	given	handle.	

	

Set	Default	ACAD	Version	(	PDCRSDA	):	



	

	

	

	

PREDCR SHORT-CUT COMMANDS 
Layer	name	 Description	

	

Naming	Convention	 Short	

command	

_Amalgamation	 Draw	a	continuous	poly	around	

the	plots	you	want	to	

amalgamate.	

Amalgamation	contains	more	

than	one	plot	amalgamated	

together.	

All	entities	having	amalgamation	

as	their	container	entity	should	

be	uniquely	present	in	each	

amalgamation.	

I.e.	suppose	there	is	a	road	

widening	in	the	Plot	then	the	

poly	of	road	widening	should	be	

different	for	each	amalgamation.	

(For	amalgamation,	draw	plot	1,	

plot	2,	plot	3	on	plot	layer	and	

amalgamated	plot	AmalPlot	1,	

on	amalgamation	layer	

overlapping	plot	1.)	

	 AMLG	

_Amenity	 Draw	Amenity	space	as	a	closed	

polyline	which	is	reserve	for	

utilities,	services	and	

conveniences.	

	

	 AMN	



	

	

_AppRoad Description:	-	Draw	Approach	

Road	as	a	closed	polyline	with	

text	specifying	its	width.eg.1.5	

m.	wide	Approach	Road. 

	 .R6 

_ArchProj	 This	layer	is	used	to	represent	

various	Architectural	

Projections	in	your	Plan.	Draw	a	

closed	Polyline	for	Architectural	

Projections.	And	mark	it	using	

Mark->Projection	from	PreDCR	

menu,	according	to	

requirements.	Canopy/porch	

will	come	in	plot	&	other	

projections	will	come	with	floor	

plans.	

	

Mark	->	Projections	-

>	Chajja	

	

AP	

_Balcony	 Draw	a	balcony	as	a	closed	

polyline	which	is	a	horizontal	

projection	including	parapet	to	

serve	as	a	sitting	out	place.	

Name	of	balcony	must	be	inside	

and	on	_Balcony	layer.	

	

	

Mark>	Balcony	>				

Enclosed	Balcony	or	

Unmark	(default)	

	

BL	

_BasementLine Description: - Draw a open 

polyline on this layer to represent 

various water bodies. 

	

	 BAS 

_Building	 Building	is	used	to	group	all	

floor	plans	of	the	same	building.	

		Draw	a	closed	poly	enclosing	all	

	

Naming	Convention	

will	be		

BLD	



	

	

the	floor	plans	and	section	of	the	

same	building	on	_Building	layer.	

Note:	As	written	above,	

dimension	or	area	of	this	

building	poly	has	no	meaning	in	

AutoDCR.	This	is	just	an	logical	

group	of	all	floors	of	the	same	

building.	If	the	building	plans	of	

multiple	PWorks	or	wings	are	

same	then	building	name	shall	

be	as	given	aside.	

	

provided	by	

Tool>Assign	Name	

A	(Bldg.Name)	

inside	Bldg.Poly	&	

A-1	(Bldg.Name)	

inside	Pwork	Poly	

	

_CarpetArea	

Draw	carpet	area	as	a	closed	

polyline	which	is	a	net	usable	

floor	area	within	a	building	

excluding	that	covered	by	the	

walls	or	any	other	areas	

specifically	exempted	from	floor	

space	index	computation	in	

these	regulations.	

	

If	CarpetArea	is	

Splitted	–	Tenement.	

Mark->	CarpetArea-

>	normal	(default)	

	

CPT	

	_Chowk	 Draw	a	chowk	as	a	closed	

polyline	which	is	an	enclosed	

space	permanently	open	to	the	

sky	within	a	building	at	any	

level.	From	chowk	we	take	

ventilation	for	habitual	rooms	

	 CWK	

_CommFSI	 Draw	a	CommFSI	as	a	closed	

polyline	which	is	the	area	

covered	by	a	building	on	all	the	

	

No	need	to	give	

name	on	this	layer.	

CMFS	



	

	

floors.	This	FSI	polyline	mainly	

used	for	commercial	use	bldg.	

	

_CompoundWall	 Closed	polyline	of	compound	

wall	to	be	drawn	on	this	layer	

overlapping	plot.		

	

	

1.5m	high	

compound	wall	

CW	

_DPRoad Description:	-	Draw	a	DP	Road	

as	a	closed	poly	line	with	Text.	

(eg	:	any	DProad	passing	from	

inside	of	the	plot)(Note:	Road	

width	must	be	written	at	the	

starting	of	Text). 

	 R7	

_DisputedArea	 Description:	-	Draw	a	closed	

poly	around	the	disputed	area	if	

any	in	your	proposal.	Eg:	

Encroachments	or	area	which	

are	not	in	your	possession	can	

be	drawn	on	this	layer.	

	 DA	

_Door	 Door	is	a	closed	Polyline	Which	

is	drawn	on	“_Door”	layer.	Also	

you	can	insert	a	particular	size	

poly	for	Door	using	Insert->Door	

from	PreDCR	menu.	

	

	

Insert->	Door	

DR	

_DrainLine Drain	Line	shall	be	drawn	as	a	

open	polyline	on	this	layer. 

	 L5	

_Electline	

	

	

Electric	line	will	be	present	in	

the	layout	plan	and	shall	pass	

through	plot	entity	as	a	non	

	

33	KV	High	Tension	

Line	

L1	



	

	

	

	

closed	polyline.	

			Name	electric	line	shall	start	

with	its	voltage	capacity	and	text	

insertion	point	shall	lie	on	its	

polyline.	

	

_ExStructure	 Draw	a	Exstructure	as	a	closed	

polyline	which	is	a	building	or	

structure	existing	authorized	

before	the	commencement	of	

these	regulation.	And	mark	it	

using	Mark	->	Existing	structure	

as	'To	be	demolished'	or	'To	be	

retained’.	

	

	

Mark->	Existing	

Structure->	To	be	

Demolished				OR			

To	be	Retained							

ES	

	_ExistRoad Description:	-	Draw	existing	or	

proposed	D.	P.	(Development	

Plan)	road	or	T.	P.	(Town	

Planning)	Road	when	

inside/intersected	with	plot.	

While	giving	name	start	text	

with	road	-width. 

	 R3	

_Floor	 Floor	poly	should	be	drawn	as	a	

closed	Polyline	with	Text	on	

same	Layer.	This	is	just	a	logical	

Group	of	all	floor	Entities.	

											Floor	Name:	Floor	Plan	

will	be	automatically	link	with	

Section	by	matching	the	Floor	

Name.	Hence	all	names	to	be	

Naming	Convention	

will	be		

provided	by	

Tool>Assign	

Name>Floor	name	

	

Name	of	floor	should	

be	in	given	format:	

FLR	



	

	

given	using	<Assign	Name>	

function	

TYPICAL-1,4	FLOOR	

PLAN	

TYPICAL-1-5	FLOOR	

PLAN	

TYPICAL-2&3	

FLOOR	PLAN	

Ground	Floor	Plan	

_FSISurrenderToCorpo Description:	-	In	case	of	

accommodation	reservation,	the	

plot	area	or	FSI	to	be	

surrendered	to	Rajasthan	is	to	

be	drawn	on	This	layer.	With	

text	inside	it. 

	

	

STC	

_GroundLevel	 The	Ground	level	line	should	be	

drawn	as	an	open	polyline	in	the	

section	poly.	

Prop.Ht.	will	be	considered	from	

GroundLvl	Polyline	

	

	

No	need	to	give	

name	on	this	layer.	

	

	

GL	

_IndFSI	 Draw	a	closed	FSI	Polyline,	

which	is	used	as	a	Industrial	

Purpose.	

	

No	need	to	give	

name	on	this	layer.	

IFSI	

_InternalRoad	

	

Draw	each	Internal	Road	as	a	

closed	Polyline	with	Centre	Line	

(Ltype-CentreLine)	&	single	text	

inside	it.	

	

	

7.50	m	wd.	Internal	

Road	

R2	

_Lift	

	

Draw	a	Lift	as	a	closed	polyline	

which	is	a	mechanically	guided	

Naming	Convention	

will	be		

LFT	



	

	

car,	platform	or	transport	for	

persons	and	materials	between	

two	or	more	levels	in	a	vertical	

or	substantially	vertical	

direction	

	Fire	Lift	means	a	special	lift	

designed	for	the	use	of	fire	

service	personnel	in	the	event	of	

fire	or	other	emergency.	

	

provided	by	

Tool<Mark>Lift>free	

from	FSI		

Tool<Mark>Lift	>	

Taken	in	FSI	

(default)	

	

	

_Locationplan	

	

Location	plans	if	any	to	be	

drawn	on	this	layer.	This	is	only	

for	reference.	No	verifications	

are	done	by	AutoDCR	for	this	

layer	so	not	compulsory.	

	

	 LCP	

_Marginline	 Margin	Polylines	will	be	created	

by	PreDCR	by	using	Tool	

"Mark>Margins"	

(User	need	not	do	anything	on	

this	layer.)	

	

	 L3	

_MainRoad	

	

	

Draw	Main	Road	as	a	closed	Poly	

with	Text,	which	should	be	

abutting	with	the	Plot	closed	

Poly.	

(Note:	Road	width	must	be	

written	at	the	starting	of	Text)	

	

24.00	m	wd.	Main	

Road	

R1	

_Nala	 Draw	centre	Line	of	Nala	as	an	

open	Polyline	on	this	layer.	

	 R4	



	

	

Name	of	the	poly	should	contain	

width	of	the	Nala	

	

_NetPlot	 No	need	to	draw	NETPLOT.	This	

layer	is	not	provided	for	PreDCR	

users..	

No	need	to	give	

name	on	this	layer.	

	

NPLT	

	

_OpenSpace Description	:	-	Draw	Open	

space	as	closed	polyline	

reserved	as	recreational	space	

on	this	layer.	With	text	on	same	

layer. 

	 	

OPS	

_Parking	 Draw	a	closed	Polyline	for	

Parking	on	“_Parking”	Layer.	You	

can	also	use	Insert	function	to	

insert	desired	Parking	Poly	in	

your	drawing.	

	

	

Insert->	Parking-

>Car-/	Scooter/	

cycle	/Fabricated	

cycle	stand		

/Loading/unloading	

space/	Visitor	

Parking	Text	/Auto	

Numbering	to	

parking	

PK	

_Passage	

	

	

Draw	a	closed	polyline	on	

“_Passage”	Layer	to	represent	

passage	with	Centre	Line	

(Ltype-CentreLine)	&	single	text	

inside	it.	

	

(Note:	If	Premium	for	Passage	is	

going	to	be	Paid,	Passage	should	

be	marked	by	using	Tool	"Mark	"	

	

Mark	>	Passage	>	

Free	from	FSI	paid	/	

unpaid		or	Taken	in	

FSI.(default)	

	

	

	

	

PAS	



	

	

	 	

_Plot Description:	-	Draw	a	Plot	poly	

as	a	closed	polyline	which	is	a	

parcel	or	piece	of	land	enclosed	

by	definite	boundaries.A	Plot	

will	contain	all	Proposed	Works	

(buildings,	wings),	open	space,	

Internal	Roads,	Parking	etc.	The	

overall	Plot	Entity	represent	a	

Plan,	AutoDCR	refer	it	as	

"Layout	Plan".	

	

	

	

	

	

PLT	

_Podium	 Draw	a	closed	polyline	on	

“_Podium“	to	represent	Podium.	

It	should	be	shown	in	the	layout	

and	not	in	floor	plans	

	

	

.	

POD	

_PropWork	 PWork	is	a	building	profile	and	

shall	be	drawn	inside	plot.	Draw	

a	closed	polyline	for	Proposed	

Work	on	“_PropWork”	Layer.	

	

	

Tools	>	Assign	Name	

>		

Building	and	

PropWork.	

PW	

_PropAccessRoad Description:	-	Draw	the	road	

which	is	proposed	as	right	of	

way	by	the	user	on	this	layer.	It	

is	similar	to	internal	road	except	

that	the	margins	required	will	

be	same	as	front	margins. 

	 R8 



	

	

_RailLine	 Railway	line	shall	be	drawn	in	

the	layout	plan	as	a	Open	Poly	&	

Text	which	insertion	point	lies	

on	the	Polyline.	

(Note:	Railway	Gauge	must	be	

written	at	a	starting	of	Text)	

	

	

__	Meter	Gauge	

Railway	Line	

L2	

_Ramp	

	

Draw	a	Ramp	as	a	closed	

polyline	with	Centreline	(L-type-

Centre)	&	Text	inside	it	in	Plan.	

	

	

10.0m	long	1.5m	

high	Ramp	

SECR	

_RefugeArea	

	

A	closed	polyline	with	Text	

around	the	refuge	area	should	

be	drawn	on	same	Layer.	

Refuge	area	should	be	outside	

overlapped	with	FSI	(ResiFSI,	

CommFSI)	poly.	

	

	 RFG	

_ResiFSI	 Draw	a	ResiFSI	as	a	closed	

polyline	which	is	the	area	

covered	by	a	building	on	all	the	

floors.	This	FSI	polyline	only		

used	for	residential	use	bldg	or	

floor.	

	

	

No	need	to	give	

name	on	this	layer.	

MFS	

_ReservArea	 If	there	in	any	Reservation	Area	

in	Plot,	it	should	be	drawn	as	a	

closed	Polyline	with	Text	inside	

same	Layer.	

	

	 RSA	



	

	

_Road	Widening	 Road	Acquisition/Road	

Widening	area	shall	be	drawn	as	

a	closed	Polyline	with	Text	on	

same	layer	inside	Plot	Entity.	

Margin	will	be	generated	&	

checked	from	Roadwidening	

Poly	by	AutoDCR	software.	

	

	 R5	

_Room	 .	

A	closed	polyline	for	each	room	

with	its	text	inside	should	be	

drawn	on	this	layer.	Text	should	

be	given	using	<Assign	Name>	

function	

	

	

	

Assign	Name	>	

Room	

RU	

_Section	 Section	poly	should	be	drawn	as	

a	closed	Polyline	with	Text	on	

same	Layer.	It	is	used	to	group	

all	Sectional	detail	like	

FloorInSection,	Plinth,	Stair	

cabin	,	Tank	etc.	

(This	is	just	a	logical	Group	of	

Sectional	Entity).		

(Note:	Area	or	size	of	Floor	

doesn't	have	any	meaning	in	

AutoDCR)	

	

	 SEC	

_SectionFloor Description: - Draw a 

SectionFloor as a closed polyline 

which is the height of that floor 

	 SECF	



	

	

(slab top to slab top) This poly 

only used for checking floor 

height. For assigning the name of 

SectionFloor use Assigned name 

option from PreDCR tool menu. 

Name of each section floor will be 

same as of floor in plan. 

  For one typical floor plan 

multiple floor section will be 

there. 

For e.g. for one typical floor plan 

for 1-3 floors there will three 

sections shall be drawn with name 

"First Floor Plan", "Second Floor 

Plan" and "Third Floor Plan" 

respectively. 

	

_SitePlan	

	

The	encapsulating	poly	around	

the	Site/Key	Plan	with	the	Text	

&	Scale	inside	it.		

	

	

	

	

STP	

_StairCase	 Total	Staircase	area	should	be	

drawn	as	a	closed	polyline	with	

text	inside	it.	

This	Main	Stair	Poly	should	

contain	Intermediate	Landing,	

Floor	Landing	&	Each	Tread	as	

an	open	polyline.	

	

Mark->	Stair	Case->	

Fire	Escape	Staircase	

OR	Fab/Spiral	Stair	

	

Mark->	Staircase	

/Free	From	FSI	

STR	



	

	

Intermediate	&	Floor	Landing	

Poly	can	be	Marked	by	PreDCR	

Tool	"Mark>Staircase>Int.	or	

Floor	Landing"	

(Note:	If	Premium	for	Staircase	

is	going	to	be	Paid,	Staircase	

should	be	marked	by	using	Tool	

"Mark>Staircase>Free	from	FSI"	

	

>paid/unpaid		

Or	taken	in	FSI	

(default)	

Intermediate	

Landing->	Flight	

Width	>	Floor	

Landing	

_StepFirst Description:	-	Draw	a	closed	

poly	which	will	represent	the	

StepFirst	in	case	of	a	

combination	of	Amalgamation	

and	Subdivision	process.	It	

represents	the	logical	grouping	

of	all	entities	to	be	treated	as	the	

1st	step	in	case	of	a	

combination.	.eg:	if	4	plots	are	to	

be	amalgamated	to	get	1	plot	

and	then	that	1	plot	is	further	

divided	to	get	3	plots	then	the	

sketch	with	_Plot	and	

_Amalgamation	will	be	bounded	

by	StepFirst	poly	of	any	shape	

and	the	sketch	with	_Plot	and	

_Subdivision	will	be	bounded	to	

by	StepSecond	poly. 

	 SF. 



	

	

_StepSecond	 Description:	-	StepSecond	is	

used	to	group	all	amalgamations	

or	subdivisions.Draw	a	closed	

poly	enclosing	all	

amalgamations	or	

subdivisions.This	layer	is	used	

only	when	you	have	

combination	case	such	as	

'Amalgamation+SubDivision'(i.e.	

A+S)	or	

SubDivision+Amalgamation'(i.e.	

S+A).If	you	are	going	for	'A+S'	

case	then	always	draw	

_SubDivision	poly	inside	

_StepSecond	poly.And	If	you	are	

going	for	'S+A'	case	then	always	

draw	_Amalgamation	poly	inside	

_StepSecond	poly.	

	 SS	

_SpecialUseFSI	 A	closed	poly	represents	a	other	

than	Residential	,	commercial	or	

Industrial	use	FSI	or	Floor	FSI.		

It	will	cover	whole	area	which	is	

considered	in	FSI	Area	per	Floor.	

	

	 SUF	

_SubDivision	 In Subdivision one plot  is divided 

into more than one Subdivisions. 

All entities having subdivision as 

their container entity should be 

uniquely present in all 

Subdivisions of a Plot i.e. suppose 

	 SBD	



	

	

there is a road widening in the Plot 

then the poly of road widening 

should be different for each 

Subdivision( subdivided plot). 

_SubPlot(RowHouse) A SubPlot in Layout should be 

drawn on this layer. 

	 SP	

_SubStructure	 SubStructures	which	are	

allowed	in	Margins	or	Layout	&	

Free	from	FSI	should	be	drawn	

as	a	closed	polyline	with	text	

inside	it.	

Name	of	the	

SubStructure	can	be	

assigned	from	

Mark>SubStructure	

tool.	

SSTR	

_Tank	 Tank	clear	size	should	be	drawn	

as	a	closed	Polyline	with	Text	on	

this	Layer	in	Floor	Plan	or	Plot	

as	well	as	Section	with	same	

Text.	

(Note:	It	should	be	in	proper	

Naming	convention	which	is	

Provide	by	Predcr	by	using	Tool.	

	

Assign	Name>Tank			 TNK	

_Terrace	 Closed	polylines	around	the	

terraces	to	be	drawn	on	this	

layer.	If	the	terrace	is	used	

commonly	by	all	tenements	

mark	it	as	Common	Terrace	else	

it	will	be	treated	as	Individual	by	

default.	

	

	 TER	

_WaterBodies Description:	-	Draw	a	open	

polyline	on	this	layer	to	

	 VB	



	

	

represent	various	water	bodies. 

_VentiShaft	 Draw	Ventilation	shaft/duct	area	

as	a	closed	Polyline	with	Text.	

Inside	FSIArea	on	_VentiShaft	

Layer.	Only	those	shafts	from	

which	ventilation	for	habitable	

room	is	not	taken	should	be	

drawn	on	this	layer.	

	

	

	

AVS	

_Void If the space is not Chowk then it 

can be void. All ducts (where 

ventilation is not taken) and 

double height rooms can be drawn 

in void layer. 

 

 VD 

_Waterline Draw a open polyline on 

“_Waterline” to represent water 

lines. 

 L4 

_Window Draw a closed polyline on 

_Window” Layer to represent 

window. You can also use Insert 

tool to insert window poly for 

particular size. 

Insert > window WND 

	

	



	

	

Specifications	to	be	followed-		

The	drawing	entities	should	be	drawn	on	Automatic	layers	created	by	using	PreDCR.	

Plot	layout,	detailed	floor	plan	and	building	section	for	all	the	floors	should	be	there	in	one	

AutoCAD	drawing	file.			

All	building	items	like	proposed	plot,	proposed	work,	proposed	parking	etc	must	be	drawn	

using	closed	polyline.	

(i.e.	Every	entity	must	be	closed	LWPOLYLINE	except	Railway	Line	,	Drain	line,	Water	Line,	

Electric	Line,	Dead	Wall	and	Ground	level.).		

Building	Sub-Items	must	be	exactly	inside	of	outer	closed	polygon	as	per	their	place	

in	architectural	plan.	

This	means	none	of	the	edge	or	vertex	of	inside	entity	should	be	drawn	outside	its	container	

entity.	For	example	Parking	or	Open	Space	poly	must	be	exactly	inside	the	main	plot	poly.	Tools	

are	provided	in	PreDCR	to	verify	this	check.		

Every	Building	Sub-Items	should	be	given	a	specific/unique	name	(Text	or	MText	entity)	on	the	

same	layer	&	inside	the	entity	poly.	As	far	as	possible,	this	name	should	be	unique.	If	name	not	

found	then	AutoDCR	will	generate	the	name	automatically.	Naming	Conventions	should	be	

followed	properly.	

e.g.		Each	Room	should	be	given	the	concerned	name	Using	<Assign	Name>	function	of	PreDCR	

Living,	Kitchen,	Bedroom.	Etc.	Floor	Name:	GROUND	FLOOR;	TYPICAL	FLOOR	1,2	&	5-8;	

TERRACE	FLOOR.	Floor	Items:	Room	Names	should	be	given	properly	without	using	

abbreviations	so	the	software	can	identify	perfect	entity.	This	can	be	done	by	Assign	name	

facility	provided	by	the	software.	

User	shall	use	only	following	kind	of	entities	for	Building	Items	:-		

LWPOLYLINE	/	TEXT	/	MTEXT	

If	in	a	plan	two	proposed	work	are	mirrored	in	that	case	user	should	provide	two	separate	

building	plan	for	each	proposed	work.	

	



	

	

Sample cases 
Residential	Bldg	(Row	house)	

	

		



	

	

Residential	bldg.	(Single	Detached	with	two	buildings)	

	

	

Commercial	building	

	



	

	

	Industrial	Building	

	

Special	building	(School	bldg)	

	



	

	

	

Meaning of various PreDCR Messages 
Entity	contain	more	than	one	text"		

						It	means	Entity	on	this	layer	contain	more	than	one	text.	So	remove	the	extra	text.	PreDCR	
need	only	one	text	for	one	entity.	

	

"Entity	not	contain	any	text"		

							It	means	This	entity	not	having	any	name/text,	so	give	the	name	to	this			entity	on	this	layer	

	

"Polyline	is	not	in	a	proper	format"		

								It	means	Highlighted	polyline	not	drawn	properly.	So	redraw	that	polyline	&	check	the	

properties	of	that	polyline.	

"Entity	is	not	closed"		

							It	means	the	highlighted	entities	not	a	closed	polyline	so	close	it	by	using	'pedit'	command.	

	

"Entity	is	supposed	to	inside	one	of	the	following	entities"		

							It	means	this	highlighted	entity	should	be	present	inside	the	one	of	the	entities	present	in	

the	given	list“	

	

"Entity	is	supposed	to	touching	one	of	the	following	entities"		

						It	means	this	highlighted	entity	is	supposed	to	be	touched	one	of	the	entities	in	given	list	

	

"Entity	should	be	outside	overlapped	with	following	entities“	

						It	means	the	highlighted	entity	should	be	outside	overlapped	with	one	of	the	th	entities	in	

the	given	list.	

Entity	must	contain	one	of	following	entities“	

						It	means	any	one	layer	should	be	present		inside	in	this	entity	which	is	listed.	

	

Following	subentities	are	not	found	inside	:		

					Direction	Ref	Point	on	layer	_Floor,	



	

	

				Type	:BLOCK,	Color	:ByLayer	Status	:	

				Common	Point	on	layer	_ResiFSI,	

				Type	:BLOCK,	Color	:ByLayer	Status	:	

				It	means	insert	the	direction	reference	circles	in	side	of	that	entities.	

	

"The	corresponding	Building	not	found	with	same	name"		

					It	means	that	proposed	work	not	having	building	with	same	name.	So	assigned	that	building	

with	having	same	name	of	proposed	work.	

"Mark	Substructures	using	PreDCR	mark	Substructure	tool"			

								It	means	mark	the	substructure	by	using	mark	->	Substructure	menu.		Do	not	type	

substructure	name	manually.	

	

"The	lift	machine	room	not	found	in	building"		

								It	means	lift	machine	room	having	name	not	same	in	Plan	&	in	section.	

	

"The	lift	poly	is	not	suppose	to	be	touch	lift	machine	room"		

								It	means	Lift	machine	room	should	be	touch	to	lift	poly	in	the	section.	

	

	‘Invalid	objects,	Please	Try	again"		

								It	means	If	user	marking	balcony	as	a	enclosed			but	selecting	layer	of	terrace	then	this	

message	are	getting.	If	selected	entity	is	incorrect	then	invalid	objects	message	are	showing.	So	

select	correct	layer	for	particular	of	that	layer	marking	only	

"Section	not	found"		

						It	means	If	all	the	floor	plans	are	drawn	but	one	of	them	in	section	floor	are	missing	to	

converting	floor	in	section	layer	then	this	message	are	getting.	So	draw	all	the	floor	plans	with	

floor	in	sections.	

	

"The	corresponding	entities	not	found	in	section"		

						It	means	that	listed	entities	not	present	in	the	section	so	show	that	entities	in	the	section.	

	

"The	corresponding	entities	not	found	in	floor"		



	

	

						It	means	that	listed	entities	not	present	in	the	floor	so	show	that	entities	in	the	floor	plan.	

	

“Two	Tanks	should	not	have	same	Name”	

						It	means	that	two	tanks	not	having	a	same	name.	So	assigned	two	tank	by	using	Assigned	

name	PreDCR	menu.	
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