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Document outline 

About the drawing protocol document 

Rajasthan government has planned to automate the building plan approval process by introducing 

AutoDCR system. AutoDCR software reads the CAD drawings and BIMDCR software reads the .IFC 

models submitted by architects and automatically produce the deviation report based on the control 

regulations prescribed by government.  

The purpose of this document is to establish a set of guidelines to Architects for preparation of 

drawings to be submitted for taking Building Permission from authority, Uniformity in the process of 

drafting of the drawings to be submitted for approval is required for automation of building approval 

system by introducing AutoDCR/BIMDCR system.  

The consultants/Architects should prepare the drawings keeping specific objects in specific layers 

with specific colors and text.  The layers required to be generated with explanation of what is 

required to be drawn on which layer is described in this document. This document serves as a source 

of information on obtaining level of consistency in drafting and approval process focuses on both the 

theoretical and practical description of process flow and protocol to be used while preparing 

drawings for submission.  

The Consultants/Architects can be prepared drawing with the help of this document. Document 

contains three sections. 

 Creation of standard layers manually in AutoCAD  

 Use of Drawing Template  

 Use of PreDCR utility.  

 Use of 3D pre-check utility 

 

 How to read this drawing protocol document? 

This document should be read in conjunction with the building bye-laws which will be applicable for 

approval of a proposal.  The reader of this document should have understood the applicable bye 

laws for scrutiny of a proposal. The reader should also be familiar with AutoCAD terminology and 

environment for better understanding of the system. It is more exploratory in nature than the 



 

 

specifications and contains sections to explain particular aspect of planning and designing. 

 

Approach for preparing drawing using set guidelines/protocol 

AutoDCR is a unique and innovative approach to automate scrutiny of building proposals by 

reading CAD/BIM drawings. AutoDCR software needs preformatted drawings with some 

specifications. Applicant/Architect can choose any of the following 3 options to prepare his 

drawing in the required format. 

Preparing 2D drawings for getting approvals from authority- 

Option 1- Architect can refer list of layer names and respective layer colors/text provided in the 

section 1 of this document and prepare the layers manually using AutoCAD’s layer creation 

commands.(Reference: Section 1 of this document). 

 Option 2-Architect can download ‘Standard CAD drawing template’ (Drawing Template.dwg) file 

available on https://swcs.rajasthan.gov.in/BPAS/PreCheck.aspx .All the layers required for 

preparing submission drawing will be available in this template drawing. User can prepare 

drawing using these pre-generated layers and text protocol defined in the protocol document. 

(Reference: Section 2 of this document).   

  Option 3- Architect can download a CAD based utility from 

https://swcs.rajasthan.gov.in/BPAS/PreCheck.aspx .  Using this utility, architect can create 

required layers automatically in the drawing, insert required text and objects in the drawing. 

This utility will also check drawing integrity and highlight drafting errors present in the drawing. 

(Reference: Section 3 of this document).   

Preparing 3D Model for getting approvals from authority- 

Download Pre-check utility from https://swcs.rajasthan.gov.in/BPAS/PreCheck.aspx. User can use 

pre-check utility to prepare model in the required format. (Reference: Section 4 of this 

document).   

 

Section I 

https://swcs.rajasthan.gov.in/BPAS/PreCheck.aspx
https://swcs.rajasthan.gov.in/BPAS/PreCheck.aspx
https://swcs.rajasthan.gov.in/BPAS/PreCheck.aspx


 

 

Creation of standard layers manually in AuoCAD 

The consultants/Architects should prepare the drawings keeping specific objects in specific layers 

with specific colors code and text. The layers required to create with explanation of what is required 

to be drawn on which layer is described in this section. 

  

How to Refer following Table 

User can prepare drawing in any Computer aided design software which file extension would be 

“.dwg” by using this document few steps are given below.  

If user is using an AutoCAD:  

Step 1: Open AutoCAD on your desktop  

Step 2: open layer dialog to create layer like this 

 
Note: In above dialog selected color would be default color code of this layer 

   Once create layer then need to draw in drawing  



 

 

 
 

Step 3: If Color need to change any entity then go to AutoCAD tool bar and select 

color as mentioned in below screen. 

 

Step 4: Type required text by referring ‘Text’ column from table below, Select line type 

mentioned in the line type table below. Refer remarks column to avoid pre-formatting 

errors. 

 

Note: All entities in drawing must be closed poly lines except mentioned in remarks against respective 

layers.  

 

Layer List Table 



 

 

Sr. 
No. 

Layer Name Color/Col
or index 

Required text 
Format 

Line Type Drawing 
Domain 

Remarks 

1 _Amenity Cyan AMENITY ByLayer Inside of Plot 
poly line 

Draw a closed polyline on 
this  layer with its text . 

2 _ArchProj  21 CHAJJA ByLayer Inside of Floor 
Polyline and 
overlapped 
with any FSI 
polyline 

All types’ projection to be 
drawn on same layer like 
chajja, Flower bed, 
cornice, loft, etc.  
Default color of this layer 
is “21” 

21 OTTA 

21 STEPS 

21 C.B. 

21 F. B. 

21 CANOPY/PORCH 

21 LOFT 

21 ARCHPROJ 

3 _Balcony 25 BALCONY ByLayer  Inside of floor 
but Outside 
overlapped 
with any FSI 
Polyline  

Balcony projection to be 
drawn on _balcony Layer 
with respective text and 
color.  
Default color of this layer 
is “25” 

230 (ENC) BALCONY 

4 _Building  52  
 

A (BUILDING)  
 

ByLayer  

 
Outside of 
Plot Polyline  

Provide building name 
with matching with its 
proposed work which is 
shown in layout.  

5 _Column 29 No Text required  ByLayer  
 

Inside of 
Parking 
Polyline 

Draw a closed polyline on 
this layer. 

6 _CarpetFSI 191 101, 102, etc.  
 

ByLayer  
 

Inside of   
Floor / FSI 
Polyline  

Give text of units no If 
normal dwelling units.  

191 SPLIT 01, SPLIT 02, 
etc.  

ByLayer  
 

Inside of  
Floor / FSI 
Polyline  

Give text of units no if it 
is splitted.  

7  _Chowk 180 CHOWK  ByLayer  Inside of Floor 
/ FSI Polyline  

Draw a closed polyline on 
this  layer with its text . 

8 _CommFSI 150  No Text Required ByLayer Inside of Floor 
Polyline  

Draw a closed polyline on 
this  layer if commercial 
building/structure is 
proposing in drawing  

200 ByLayer Color should be 200 if it 
is existing area 

9 _CompoundWall 252 1.50m High Comp 
Wall.  

ByLayer Overlap with 
Plot poly line  
 

Need to mention 
compound wall height in 
its text.  

10 _Door 114  
 

D1, D2, D3, etc.  ByLayer  Inside of Floor 
/FSI 
/Substructure 
Polyline  

Need to provide D1, D2, 
D3, text to calculate no of 
doors and its text should 
be inside door poly.  

11 _DeadWall yellow Deadwall ByLayer Overlap with 
Propwork as 
open poly line  
 

Text should be kept on 
same layer and color. 

12 _Driveway 190 12.0 M Wide 
Driveway 

ByLayer Inside of 
Parking Floor 
and Plot 

Draw a closed polyline on 
this  layer with 
mentioning its width in 
its text . 



 

 

13 _SewageLine 10 DRAINAGE LINE ByLayer Inside of  plot 
poly line 

Poly line should be drawn 
as open polyline and 
12provide its text with 
intersecting open 
polyline on same layer 
and color  

14 _Electline 241  33 KV High Tension 
Line  

ByLayer  Inside/interse
ct with Plot  
 

Need to mention voltage 
of the electric line in its 
text. 

15 

 

_ExStructure Blue Existing building1, 2, 
etc.  

ByLayer Inside of plot 
poly line 

Color to be kept blue if 
existing structure is to be 
retained 

242 ByLayer Color to be changed as 
242 if existing structure is 
to be demolished 
Default color of this layer 
is “Blue” 

16 _Elevation  44 ELEVATION ByLayer Inside of 
building 
polyline 

Draw a closed polyline on 
this  layer with its text . 

17 _EWS 190 No Text Required ByLayer Inside of FSI 
Poly line / 
overlap FSI 
poly line 

Draw a closed polyline on 
this  layer. 

18 _Floor  153 GROUND FLOOR 
PLAN, FIRST FLOOR 
PLAN, Typical-1,3,5 
FLOOR PLAN, Etc.  

ByLayer  
 

Inside of 
building 
Polyline  
 

Floor name must be 
matched with its section 
on section floor layer.  

19 _SectionFloor 132 GROUND FLOOR , 
FIRST FLOOR,  
SECOND FLOOR, 
Etc. 

ByLayer  
 

Inside of 
Section 
Polyline  
 

Draw each floor’s section 
on “_SectionFloor” 
polyline with mentioning 
text inside poly line. 

20 _GroundLevel 63 GL ByLayer Inside of 
Section 
polyline 

Draw a open poly line on 
this layer and mention 
text as GL with insertion 
point overlapping with 
polyline.  

21 _IndFSI 163 No Text Required ByLayer  
 

Inside of Floor 
Polyline  

Draw a close polyline on 
this layer if Industrial 
use/structure is 
proposing in drawing  

200 ByLayer Color should be 200 if it 
is existing area 

22 _IntRoad Green 6.0m Wide Int. Road  ByLayer  Inside of  Plot 
Polyline  

Draw a closed poly line 
on this layer and mention 
road width in its text. 
Also draw open polyline 
inside Internal Road with 
Line type as centre  

23 _Lift 11 LIFT ByLayer  Inside of Floor 
/FSI / Parking 
/ Terrace 
Polyline  

Draw a closed polyline on 
this  layer with its text . 
Mention Fire word if it is 
fire lift like “FIRE LIFT” 
other wise “LIFT”  



 

 

24 _LIG 190 No Text Required ByLayer Inside of FSI 
Poly line / 
overlap FSI 
poly line 

Draw a closed polyline on 
this  layer. 

25 _LocationPlan  
 

211 LOCATION PLAN  ByLayer  Outside of 
building and 
plot 

Draw a closed polyline on 
this  layer with its text . 

26 _Marginline 253 No Text Required ByLayer Overlapped 
with NetPlot 

Draw lines on this layer 
overlapping with 
NETPLOT poly line. Red Overlapped 

with NETPLOT 
and Main 
Road 

Magenta Overlapped 
with NetPlot 

Blue Overlapped 
with NetPlot 

27 _MainRoad 20 12.0 M Wide Main 
Road  

ByLayer  Outside 
overlapped 
with Plot 

Draw a closed polyline on 
this  layer with its text . 
Text should be start with 
mentioning road width. 
Main road poly should be 
overlapped with plot. 

28 _Nala 65 NALA ByLayer Overlap/insid
e with Plot 

Draw a closed polyline on 
this  layer with its text . 

29 _NETPLOT 145 No Text Required ByLayer  Overlapped 
with Plot  

Draw a closed polyline on 
this layer with deducting 
all types reservations 
from plot 

30 _OpenSpace Yellow  LANDSCAPPED 
AREA   

ByLayer  Inside of Plot 
Polyline  

Draw a closed polyline on 
this layer with its text. 

31 _Parking  60 Parking  ByLayer  Inside of Floor 
& Plot Polyline 
  

If parking/Stilt floor is 
present then draw a 
close polyline. 

62 CP ByLayer Draw Individual Car 
parking rectangle on this 
layer with Text “CP” and 
color index 62 

52 SC ByLayer Draw Individual Scooter 
parking rectangle on this 
layer with Text “SC” and 
color index 52 

53 CY ByLayer Draw Individual Cycle 
parking rectangle on this 
layer with Text “CY” and 
color index 53 

55 TV ByLayer Draw Individual Cycle 
parking rectangle on this 
layer with Text “CY” and 
color index 53 

71 VSP ByLayer Draw Individual Visitor 
Scooter rectangle on this 
layer with Text “VSP” and 
color index 71 



 

 

70 VVP ByLayer Draw Individual Visitor 
Car rectangle on this 
layer with Text “VVP” 
and color index 70 

54 AMB ByLayer Draw Individual 
Ambulance Parking  
rectangle on this layer 
with Text “AMB” and 
color index 54 

32 _Passage 243 PASSAGE ByLayer Inside of 
Floor/ FSI 

Draw a closed polyline on 
this layer with its text. 
Also draw open polyline 
inside Passge with Line 
type as centre 

33 _Plot White  PLOT ByLayer Outside of the 
building 
polyline  

Plot should be outside 
overlap with MainRoad. 
Text should be provided 
on same layer. 

34 _Podium 50 PODIUM ByLayer Inside of 
Plot/Floor 
Polyline  

Draw a closed polyline on 
this  layer with its text . 

35 _PropWork Red A-1 (BUILDING)  ByLayer Inside of Plot 
Polyline  

Text must be matched 
with building layer’s text  
If building poly text is “A 
(BUILDING)” then its 
proposed work text 
should be “A-1 
(BUILDING)” 

36 _RailLine 170 RAILLINE  ByLayer  Should be 
intersected 
Plot  

Poly line should be drawn 
as open polyline and 
provide its text with 
intersecting open 
polyline on same layer 
and color. 

37 _Ramp 135 10.0 M Long and 1.0 
M High Ramp  

ByLayer Inside of 
Floor, Plot 
Polyline  
 

Draw a closed polyline on 
this layer with its text. 
Length and its height 
must be mentioned in its 
text  
Also draw open polyline 
inside Ramp with Line 
type as centre 

38 _RefugeArea 79 REFUGE AREA ByLayer Inside of Floor 
Polyline  

Draw a closed polyline on 
this layer with its text. 

39 _ResiFSI 190 No Text Required ByLayer  Inside of Floor 
Polyline  

Draw a closed polyline on 
this layer if residential 
use/structure is 
proposing in drawing. 

200 ByLayer Color should be 200 if it 
is existing area. 

40 _RoadWidening 67 ROAD WIDENING  ByLayer  Inside of  Plot 
Polyline & 
should be 
overlapped 
with 

Draw a closed polyline on 
this layer with its text. 



 

 

MainRoad  

41 _Room 72 LIVING, KITCHEN, 
BED ROOM, etc.  

ByLayer Inside of Floor 
/ CarperFSI 
Polyline  

Draw a closed polyline on 
this layer with its text. 

42 _Section 75 SECTION ByLayer Inside of 
Building and 
Outside Floor 
Polyline  

Draw a closed polyline on 
this layer with its text. 

43 _Sanitation 119 WB, SINK, etc. ByLayer Inside Floor Draw a closed polyline on 
this layer with its text. 

44 _SectionFloor 132 GROUND FLOOR, 
FIRST FLOOR, Etc.  

Bylayer  
 

Inside of 
Section/ 
building 
Polyline  

Section floor name must 
be matched with its floor 
plans.  

45 _SitePlan 50 SITE PLAN ByLayer Inside of 
building 
Polyline  

Draw a closed polyline on 
this layer with its text. 

46 _SewageLine 10 SewageLine ByLayer Inside of Plot 
Polyline 

Draw a open poly line on 
this layer and provide 
text on same layer with 
insertion point should 
overlapped with polyline. 

47 _SpecialUseFSI 213 No text Required ByLayer Inside of Floor 
Polyline  

Draw a closed polyline on 
this layer, draw Special 
use FSI polyline for other 
than residential, 
commercial, industrial 
building like school, 
hospital etc.  

200 Color should be 200 if it 
is existing area. 

48 _StairCase 120 STAIR CASE or 
FAB/SPIRAL STAIR  
 

ByLayer Inside of Floor 
/ FSI/ Parking/ 
Terrace 
Polyline  

Draw a closed polyline on 
this layer with its text. 
 

120 No text Required Inside of 
staircase close 
polyline 

Draw all treads as open 
poly line. 

161 Draw intermediate 
landing as open polyline 
and color index will be 
161 

231 Draw floor landing as 
open polyline and color 
index will be 231 

49 _SubStructure 32 ELECTRIC ROOM ByLayer Inside of Floor 
Or Plot 
Polyline  
 

All these ancillary 
structure to be drawn on 
“_SubStructure” layer as 
closed polyline and 
default color index of this 
layer is “32”, if it is 
proposing in drawing. 

93 TRANSFORMER 

105 WATCHMAN ROOM 

127 SOCIETY OFFICE 
ROOM 

123 SERVANT QUARTER 

43 SANITARY BLOCK 

91 GARAGE 

175 EFFLUENT 
TREATMENT PLANT 



 

 

122 OUT HOUSE 

141 PUMP ROOM 

82 SEPTIC TANK/SOAK 
PIT 

176 WASTE WATER 
TREATMENT PLANT 

32 LIBRARY 

93 COMMUNITY HALL 

32 COMMON STORE 
ROOM 

32 COMMON TOILET 

32 SOLAR POWER 
PLANT 

32 DUB 

32 ELECTRIC SUB-
STATION 

32 SEWAGE 
TREATMENT PLANT 

32 RAIN WATER 
HARVESTING 

32 A C PLANT ROOM 

32 AHU 

32 SWIMMING POOL 

32 PUMP  HOUSE 

32 DISH ANTENNA 
ROOM 

32 VIDEO ROOM 

32 WELL 

32 TELEPHONE 
INSTALLATION 
PLANT/STP 

32 ENTRANCE GATE 

32 FITNESS CENTER 

32 SUCTION TANK 

32 GYMNASIUM 

32 CLUB- HOUSE 

32 DUST BIN 

32 MILK/TELEPHONE 
BOOTH 

32 LETTER BOX 

32 IND.CHIMNEY 

32 PARKING SHADE 

50 _Tank 133 (O/H)TANK(1) 
 

ByLayer  Inside of 
Floor, Plot & 
Section 
Polyline  
 

Over head Water to be 
drawn on floor as well as 
in section and both 
polylines texts should be 
in this format. 

(U/G)TANK(1) Under Ground Water to 
be drawn on floor as well 
as in section and both 
polylines texts should be 



 

 

in this format.  

51 _Tree green No Text Required ByLayer Inside of Plot 
Polyline 

Draw a closed poly line 
on Tree layer if it is 
available on site. 

52 _Terrace 30 TERRACE ByLayer Inside of Floor 
Polyline  

Draw a closed polyline on 
this layer with its text. 

53 _Void 111 VOID ByLayer Inside of Floor 
/FSI/ Parking / 
Terrace 
Polyline  
 

Draw a closed polyline on 
this layer with its text. 

54 _VShaft 83 SHAFT ByLayer Inside of Floor 
/FSI/ Parking / 
Terrace 
Polyline  

Draw a closed polyline on 
this layer with its text. 

55 _WaterLine 131 WATER LINE ByLayer Inside of plot 
poly line 

Poly line should be drawn 
as open polyline and 
provide its text with 
intersecting open 
polyline on same layer 
and color.  

56 _Window 115 W1, W2, V1, V2, 
etc.  

ByLayer Inside of Floor 
/FSI / 
Substructure 
Polyline  

Need to provide W1, W2, 
V1, V2, text to calculate 
no of windows and its 
text should be inside 
window poly.  

57 _DownComer 190 No Text Required ByLayer Inside of Floor  Draw a closed polyline 
tentatively of Down 
Comer if it is proposed in 
building , No need to 
provide text on this layer. 

58 _DryRiser 113 No Text Required ByLayer Draw a closed polyline 
tentatively of Dry Riser if 
it is proposed in building, 
No need to provide text 
on this layer. 

59 _FireExtinguisher Cyan No Text Required ByLayer Draw a closed polyline 
tentatively of Fire 
Extinguisher if it is 
proposed in building, No 
need to provide text on 
this layer. 

60 _HoseReel 30 No Text Required ByLayer Draw a closed polyline 
tentatively of Hose Reel if 
it is proposed in building, 
No need to provide text 
on this layer. 

61 _ManualFireAlarm 60 No Text Required ByLayer Draw a closed polyline 
tentatively of Manual 
Fire Alarm if it is 
proposed in building, No 
need to provide text on 
this layer. 



 

 

62 _WetRiser 150 No Text Required ByLayer Draw a closed polyline 
tentatively of Wet Riser if 
it is proposed in building, 
No need to provide text 
on this layer. 

63 _YardHydrant 11 No Text Required ByLayer Draw a closed polyline 
tentatively of Yard 
Hydrant if it is proposed 
in building, No need to 
provide text on this layer. 

   
Margin and Reference circles Blocks. 

Sr. 
No. 

Layer Name Block Name Block Insertion point Remarks 

1 _Resi_FSI Common Point Center of block Draw a circle on “_Resi_FSI” layer and 
make it a block on same layer with block 
name "Common Point". 

2 _Floor Direction Ref Point Center of block Draw a circle on “_Floor” layer and make it 
a block on same layer with block name 
“Direction Ref Point" 

3 _Marginline ADCR_MARGIN Center of block Create Margin Block on above created 
“_Marginline” layer from lines which are 
drawn on same layer with block name 
“ADCR_MARGIN”. 

4 _Tree Tree Center of block Crate Tree block on above created “_Tree” 
layer with block name “_Tree”  

 
 
 
 

Section 2 

Use of Drawing Template  

 

User can get download ready drawing template from following link.  

 

Section 3 

Drawing pre-formatting utility (PreDCR) 

 

Overview 



 

 

AutoDCR is a unique and innovative approach to automate scrutiny of building proposals by 

reading CAD drawings. AutoDCR software needs preformatted drawings with some 

specifications. PreDCR is a software application used to create the architectural plan as per 

AutoDCR software requirements. It helps in standardization of drawings and helps in reducing 

time required for preparing submission drawings. It works under AutoCAD as well as CAD 

independent environment with additional menu & toolbar. 

 

Using PreDCR commands user can create all the required layers in one click. Once all the layers 

are created in the drawing user can use AutoCAD commands to draw entities on the 

corresponding layers with the help of PreDCR software. Short commands are provided to activate 

any layer in PreDCR. PreDCR also helps in correcting drafting errors in the drawing. At any time 

user can verify if the drawn entities are properly closed or not, if proper name text has been 

written inside all closed poly or not etc. PreDCR will highlight all the failed entities if any. 



 

 

 

 

Aims & objectives 

To bring uniformity and standardization in submission drawing format. 

To create error free drawing by auto-correction of drafting errors. 

To Increase drafting speed and efficiency 

To reduce drawing data redundancy. 

To remove dimensioning and area calculation requirements from submission drawing format 

and auto-calculating areas in AutoDCR automatically.  

 

Salient features 

Automatically creating required layers in the drawing 



 

 

 

 

Automatically creating and inserting entites of required size in the drawing: User can define size 

of entity and insertion point in the the drawing.PreDCR will create and insert entity in the 

drawing at specified location. 

 

Automatic insertion of required text in the drawing. 



 

 

 

 

Drawing cleaning, refinements of poly lines, text and closed entity verification will be done by 

PreDCR to eliminate drafting errors. 

 

 

PreDCR verify and will highlight failed entities in verifications with detailed explanation and 

Auto-zooming. 



 

 

 

 

 

Benefits of PreDCR 

1) Standardization of submission drawings-Brings uniformity & standardization in submission 

drawing format. This software will correct some minor drafting errors and also provide list of 

failed entities with Auto-zooming facility so that user can easily locate the failed entities in the 

drawing.  

2) Operational ease and convenience-Data redundancy is eliminated from the drawing. Only 

minimum required entities are to be drawn in the drawing as most of the data will be auto 

detected by the system from existing available data. 

3) Increased speed and efficiency-PreDCR facilitates Auto insertion of many drawing entities like 

parking, door windows etc of required size and number. Test auto-insertion facility saves text 

typing efforts. Auto-dimensioning and auto-calculation facility saves calculation efforts. Using this 

software user can create all the required layers at one click.    

4) Accuracy - Accuracy in area calculations is achieved. Preparing Calculation tables, showing 

dimensions in the drawing is not required.  

 



 

 

Drawing formats 

 

1) Conventional submission drawing format  

 

 

2) As per PreDCR format specified by PreDCR  

 

 

Conventional drawing submission format 



 

 

3) After scrutiny of drawing using AutoDCR- 

 

 

Protocol details 

PreDCR is a software application used to create the architectural plan as per AutoDCR software 

requirements. It works under AutoCAD as well as CAD independent environment with additional 

menu & toolbar. 

           Using PreDCR commands user can create all the project wise required layers in one click. 

Once all the layers are created in the drawing user can use AutoCAD commands to draw layout 

plan. 

As per AutoDCR requirement all building items like plot, proposed work should be drawn on the 

corresponding layers. Short commands are provided to activate any layer in PreDCR  

At any time user can verify if the drawn entities are properly closed or not, if proper name text 

has been written inside all closed poly or not etc. PreDCR will highlight all the failed entities if 

any. 

          PreDCR can be used to modify/make and verify the existing or new architectural plan as 

per AutoDCR software requirements. Users are free to use AutoCAD commands and or PreDCR 

commands to achieve the main purpose which is: 

Drawing the architectural plan in DWG format as per AutoDCR software requirements. 



 

 

For automating the process of Development Control Regulations user/draughtsman/architect have 

to follow some specifications. The following are the list of specifications that the user should 

follow. Plot layout, detailed floor plan and building section for all the floors should be there in one 

AutoCAD drawing file.   

All building items like proposed plot, proposed work, proposed parking etc must be drawn using 

closed polyline. 

(i.e. Every entity must be closed LWPOLYLINE except Railway Line , Drain line, Water Line, 

Electric Line, DeadWall and Ground lvl.).  

Building Sub-Items must be exactly inside of outer closed polygon as per their place 

in architectural plan. 

This means none of the edge or vertex of inside entity should be drawn outside its container entity.  

       For example Parking or Open Space poly must be exactly inside the main plot poly. 

       Tools are provided in PreDCR to verify this check.  

Every Building Sub-Items should be given a specific/unique name (Text or MText entity) on the same 

layer & inside the entity poly. If name not found then AutoDCR will generate the name 

automatically. Naming Conventions should be followed properly. 

e.g.  Each Room should be given the concerned name Using <Assign Name> function of preDCR 

Living, Kitchen, Bedroom..Etc.  

Floor Name: GROUND FLOOR; TYPICAL FLOOR 1,2 & 5-8; TERRACE FLOOR 

Floor Items: Room Names should be given properly without using abbreviations so the software 

can identify perfect entity. This can be done by Assign name facility provided by the software. 

User shall use only following kind of entities for Building Items: -  

LWPOLYLINE / TEXT / MTEXT 

If in a plan two proposed work are mirrored in that case user should provide two separate 

building plans for each proposed work. 

 

Installation and Registration 

System Requirements 

         Pentium IV or better (or compatible processor) 



 

 

         4 GB RAM Minimum 

         Windows 98/2000/XP (32bit)/Vista/Windows7 (32bit or 64bit) 

       USB Port 

Installation 

To install PreDCR software on your computer please follow the given steps.  

Step 1:  Insert the supplied PreDCR CD in CD drive of the computer. 

Step 2:  Run the PreDCR installer by double clicking on file "PreDCR_Installer.exe"  

in the PreDCR CD. 

Step 3:  Follow the next steps in installer wizard to complete installation.  

 

After successful installation, a PreDCR shortcut will be placed on your computer desktop as  

shown below. 

 

Figure 1: PreDCR shortcut on desktop 

 

New Features in PreDCR version 2.0 

 



 

 

1. Option for CAD Package Independent PreDCR Environment: 

 
 Description:- 

This is a special feature provided in this latest version of PreDCR. Now user can use the 
PreDCR without any CAD package installed on their machines. This feature provides a 
CAD environment with all PreDCR command and options required. Apart from PreDCR 
commands some basic commands are also available for users for drafting purpose. 
 

 Steps:- 
o Open the PreDCR software by clicking on PreDCR icon on your desktop. Following 

dialog will appear. 

 
 

o If you want to use AutoCAD based PreDCR then select the ‘Use AutoCAD 
Compatible PreDCR’ option and select the required AutoCAD version from the 
list. Click on OK button to proceed.  



 

 

 
This will automatically open the selected AutoCAD version and the PreDCR Menu 
and Toolbar will get added in the AutoCAD environment. 
 

o If you don’t want to open the PreDCR in AutoCAD and want to use the CAD 
interface of PreDCR then select the ‘Use CAD Package Independent PreDCR’ 
option from the dialog. Click on OK button to continue. 



 

 

 
 
This will open a CAD interface with PreDCR Menu and Toolbar. Basic CAD 
commands are also available in this environment which can be used for drafting 
purpose. 
 

 



 

 

2. Layer Mapping: 

 
 Description:- 

A user friendly interface is provided for users to map his Architectural layers in drawing 
with the standard PreDCR layers. User will have to only map the layers in the dialog and 
PreDCR will automatically create the mapped layer entities in drawing on standard 
PreDCR layers. 
 

 Limitations:- 
This will only map the Architect’s layers to PreDCR layers. This will not modify all the 
entities drawn on Architect’s layer as per PreDCR requirements. User has to provide those 
entities in the PreDCR required format. (i.e. in the polyline format) 
 

 Steps:- 
o Open the drawing in PreDCR environment. 
o Click on the ‘Select Project Type’ button to select the type of proposal.  

 
 
One dialog will appear. 
 

o Select the Type of Project for the open drawing. Click on OK button. 

 
 



 

 

o If the drawing contains Layers other than PreDCR layers, then PreDCR will prompt 
you to use Layer mapping tool. 

 
 

o Click on Yes button if you want to map your layers with standard PreDCR layers. 
o After Clicking on Yes button, one dialog will appear. PreDCR will automatically 

map some of the layer names with standard PreDCR layer names.  

 
o This dialog contains the list of Layers other than PreDCR layers in drawing. 



 

 

o User can select the corresponding PreDCR layer for his custom layers in the combo 
list. 

 
 
o After mapping all your Architect layers with standard PreDCR layers click on OK 

button. 
 

o PreDCR will automatically create standard PreDCR layers and all the mapped 
custom layer entities will get shifted to corresponding PreDCR layers (which are 
mapped by user). 

 
o User can see the all the project specific PreDCR layers by using the ‘Layer List’ 

button on PreDCR toolbar. 

 



 

 

o After mapping done, use ‘Refinement of Drawing’ button on PreDCR toolbar for 
clean up of drawing. 

 
 
 

3. Verifying Failed Entities: 

 
 Description:- 

In the failed list dialog, we have provided on button to view the list of all failed entities 
with their Entity Reference. This button will invoke another dialog which will contain the 
list of all failed entities. User can see the failed entity in drawing by just clicking on the 
particular item in the list. User can make the changes in drawing for that failed entity and 
can again verify that entity using this ‘Verify Again’ option provided on this dialog. The 
status of that entity will change accordingly. In this way user can modify those failed 
entities one by one and at the same time can check its status. So no need to verify the 
complete drawing or layers to check the status of failed entities after corrections. 
 

 Steps:- 
o After completion of verification failed dialog is invoked (if any fail entity found in 

drawing).  



 

 

 
 

 

Methodology  

1)   Open the PreDCR software for clicking on PreDCR menu on your desktop & select the Use 

CAD Package PreDCR option & then click on "OK" button. 

 



 

 

 

 

2)  First open submission drg which is now converting in PreDCR format. 

 



 

 

  

3)  Save as your drg with give some name. 

 

 

 



 

 

4) Check the scale by using Scale command. If drg is not in 1: 100 scale then covert into the 1:100 

scale.& then make that drg in matric scale if it is in other than meter.  

 

 

 

 

 

5) Also make the site plan in 1:100 scale. 



 

 

 

  

6)  By using Predcr toolbar first select the Type of Project that is " Proposed Development“ , 

“Land Division” or “Plotting Layout”  

a) If Plot is Already sanctioned & user have to take permission for the buildings only then select 

“Proposed Development.” 

b) If User having Proposal is Amalgamation or Subdivision then select “Land Division” option 

from the list. 

c) If Proposal having a Plotting Layout then select that “Plotting Layout” option from the list. 

 



 

 

 

7)  By using Predcr toolbar "Create a DCR layer" that is second option in Predcr toolbar. 

 

  

 

 

8)  Then u will get the list of PreDCR toolbar , then just click on "OK" button. Now all the Layers 

u will get in Layer Properties managers. 



 

 

 

 

Now Select current Layer is "_ Plot" & Draw a closed polyline on this layer. Also give the plot 

name on that layer only. 

 



 

 

 

 

Make the current layer '_Main Road” & Draw a road on this layer. Give the Name of road which  

is starting with it's width. 

 

 



 

 

 

Make the current Layer " …….FSI" as per your project  having that use you can select that use of 

FSI. e.g. For Residential use - Select  "_ResiFSI"  poly, For Commercial use select “CommFSI” poly. 

& Draw a area key plan line on this layer. No need to give any name on this Layer 

 

 

Make the current Layer "_Carpet FSI" and draw a closed poly on this Layer which having floor 

area excluding wall area. Also give the name on this Layer. If carpet is splitted no of places but 

having only one tenement then use the Splitted tenement option from Predcr Mark menu bar. 

 



 

 

 

 

 

Make the current Layer "_Room" and draw a closed poly on this layer. If room having rectangle 

shape then u can use rectangle also. Assign the room name for using the assigned name option 

from Predcr menu bar. 

 

 

 



 

 

: Insert the doors & windows by using insert option from Predcr menubar.  

 

 

 

 

15)  Make the current layer "_Floor" and draw a boundary outside of each & every floor. 

  

 

 

16)  Make the current layer "_Tank" and draw U/G & O/H tank in plan as well as in section also. 

Assigned this tank name by using Assigned name option from Predcr menubar. 



 

 

  

 

 

17) Make the current layer "_Staircase" and draw all the riser on this layer which is a open  

polyline. Also draw two extra line on this layer which is showing a floor landing and intermediate 

landing. Then mark this landing for using staircase landing option from Predcr menu. Also mark 

the staircase which having type. For spiral and fabricated staircase no need to draw riser & 

landing marking. 

 



 

 

 

 

 18)  Make the current layer is "_Ground Level" and draw a open polyline on this layer which is 

place below the plinth level. 

 



 

 

 

 

Make the current layer is "_Building" and draw a boundary on this layer which is having a group 

of all the floors with section 

 

 



 

 

Make the current layer is "_ProposedWork" and draw a total coverage on this layer. Assigned 

this proposed work by using "Predcr->Assigned name -> Building & proposed work from Predcr 

menu. 

 

 

If project having any Substructure then draw a closed polyline on "_Substructure" layer. Also 

mark this substructure by using " Predcr-> Mark-> Substructure from Predcr menubar. 

 

 

 

If project having any Existing structure then draw a closed polyline on "_Exstructure" layer. Also 



 

 

mark this Exstructure by using " Predcr-> Mark-> Exstructure from Predcr menubar. 

 

 

 

Mark the margins by using Mark-> margin from Predcr menubar 

 

 

 

After converting all the Layers use the "Fix poly" option from Predcr menubar.  

 

 



 

 

 

 

 

 

just click on "OK" 

 

just click on "OK" 

 

 

 

When u will get these message "Refinement of Polyline is done" then select the "Verify Closed 

poly" option from Predcr menu. 

 



 

 

 

 

 

 

 

 

 

 

 

 

:  When u will get these message "Entities on Predcr Layers are verified and found o.k." then only 

u can submit a softcopy of your drg to the Corporation. 

 



 

 

 

 

 

 

 

 

 

27)   Also check the "Objection list" which user are missing to convert in Predcr layer. 

 

 

 

 

 



 

 

 

PreDCR Layer Information 

 

_Amalgamation layer: 

 

Description : 

 - Draw a continuous poly around the plots you want to   amalgamate. 

     Amalgamation contains more than one plot amalgamated    together. 

      All entities having amalgamation as their container entity should be uniquely present in each 

amalgamation. 

i.e. suppose there is a road widening in the Plot then the poly of road widening should be 

different for each amalgamation. (For amalgamation, draw plot 1, plot 2,plot 3 on plot layer and 

amalgamated plot AmalPlot 1, on amalgamation layer overlapping plot  

Verification : 

 It Should overlap with _MainPlot/plot. 

Shortcut Command : 

 - AMLG 

How to draw : 

 

 



 

 

 

 

_Amenity  

 

Description : 

 - Draw Amenity space as a closed polyline which is reserve for utilities, services and 

conveniences. 

Shortcut Command : 

 - AMN 

How to draw : 

 



 

 

 

 

 

 _ArchProj 

Description :  

- This layer is used to represent various Architectural Projections in your Plan. Draw a closed 

Polyline for Architectural Projections. And mark it using Mark->Projection from PreDCR menu, 

according to requirements. Canopy/porch will come in plot & other projections will come with floor 

plans. 

Shortcut Command: 

 - AP. 

How to draw : - 



 

 

                                      

 

_VShaft 

Description :  

- Draw Ventilation shaft/duct area as a closed Polyline with Text. Inside FSI Area on _VShaft Layer. 

Only those shafts from which ventilation for habitable room is not taken should be drawn on this 

layer. 

Shortcut Command: 

 - AVS. 

How to draw : - 

                                     



 

 

 _Balcony 

Description :  

- Draw a balcony as a closed polyline which is a horizontal projection including parapet to serve as a 

sitting out place. Name of balcony must be inside and on _Balcony layer. 

Balcony can be present in :  

Plot: It must overlap with PWork (if not enclosed) 

Floor: It must overlap ResiFSI. 

Shortcut Command :  

- BL 

How to draw : -                                 

                  

_BasementLine 

Description :  

- Draw a open polyline on this layer to represent various water bodies. 



 

 

Shortcut Command :  

- .BAS  

                               

 _Building 

Description : 

 - Building is used to group all floor plans of the same building.   Draw a closed poly enclosing all the 

floor plans and section of the same building on _Building layer. Note: As written above, dimension or 

area of this building poly has no meaning in AutoDCR. This is just an logical group of all floors of 

the same building.If the building plan of multiple PWorks or wings are same then building name shall 

be as given in table below. 

Building names can be. 

1  "A(Monarch)" PWork "A" has building plan 

"Monarch". 

2  "A,B(Monarch)" or "A&B(Monarch)" Wings A, B have same 

building plan "Monarch". 

3  "A-C(Monarch)" Wings A,B,C have same 

building plan "Monarch". 

4  "A1-A3(Monarch)" Wings A1, A2,A3 have same 

building plan "Monarch". 

Shortcut Command : 

 - BLD 

How to draw : 

 - What Building poly will have? Building poly will enclose all the floor plans in that building along.              



 

 

    

 _CarpetFSI 

Description :  

- Draw carpet area as a closed polyline which is a net usable floor area within a building excluding 

that covered by the walls or any other areas specifically exempted from floor space index 

computation in these regulation. 

Shortcut command : 

 - CPT. 

How to draw : - 



 

 

                                          

 _Chowk 

Description :  

- Draw a chowk as a closed polyline which is an enclosed space permanantly open to the sky within a 

building at any level. From chowk we take ventilation for habitual rooms. 

Shortcut Command : 

- CWK. 

How to draw : 

                                             



 

 

_Column 

Description :  

-Column shall be drawn as closed polyline on this layer. 

Shortcut Command :  

COL 

_CommFSI 

Description: Commercial FSI :  

-  Draw a CommFSI as a closed polyline which is the area covered by a building on all the floors. 

This FSI polyline mainly used for commercial use bldg. 

Shortcut Command : 

 - CMFS.    How to draw : -                

                                                 

 _CompoundWall 

Description :  

- Open polyline of compound wall to be drawn on proposed compound wall with text started with 

compound wall height. E.g. 1.5m. high Compound Wall 

Shortcut Command : 



 

 

 - CW. 

How to draw : -  

                                              

 

_DPRoad 

Description :  

- Draw existing or proposed D. P. (Development Plan) road or T. P. (Town Planning) Road when 

inside/intersected with plot. While giving name start text with road -width. 

E.g. 15m wide D.P. Road. 

Shortcut Command : 

 - R3. 

How to draw : - 

 



 

 

 

                                         

_SewageLine 

Description: -  

-  Drain Line shall be drawn as an open polyline on this layer and provide text. 

Shortcut Command :  

- L5. 

How to draw : -  

 



 

 

 

_Door 

Description :  

- Door is a closed Polyline Which is drawn on “_Door” layer. Also you can insert a particular size 

poly for Door using Insert->Door from PreDCR menu. 

Shortcut Command :  

- DR. 

How to draw : - 

                                                

 _ElecLine 

Description : - 

 Electric line will be present in the layout plan and shall pass through plot entity as a non closed 

polyline. 

Name electric line shall start with its voltage capacity and text insertion point shall lie on its polyline. 

  For e.g. 33 KV High Tension Line 

Shortcut Command :  



 

 

- L1. 

How to draw : - 

                                          

 _Elevetion  

Description :  

- Draw a elevation as a closed polyline which is a only outer line elevation  for printing  

_ExStructure 

Description : - Draw a Exstructure as a closed polyline which is a building or structure existing 

authorized before the commencement of these regulation. And mark it using Mark -> Existing 

structure as 'To be demolished' or 'To be retained’. 

Shortcut Command :  

- EX. 

How to draw :- 



 

 

                                             

 

_ExistRoad 

Description: - Draw existing or proposed D. P. (Development Plan) road or T. P. (Town Planning) 

Road when inside/intersected with plot. While giving name start text with road -width. 

eg. 15m wide Road. 

Shortcut Command : - R3. 

How to draw : - 

 

 

_Floor 



 

 

Discription: 

Draw a Floor as a closed polyline to the boundary of the lower surface in a story on which one 

normally walk in a building and including mezzanine floor also. The floor at ground level with a 

direct access to a street or open space shall be called the ground floor, the floor above it shall be 

termed as Floor 1 with the next higher floor being termed as Floor 2 and so on upward. For giving the 

name of each floor use the assign named option from the PreDCR menu. Also draw each floor 

separately. While giving name to the typical floor then use a Typical option from Assigned name -> 

Floor name option from PreDCR menu bar. 

Shortcut Command :  

- FLR 

Reference Circle : - All Floor poly must contain a circle with its center on common point for whole 

building on layer "_ResiFSI". Usually it can be placed inside either Common Lift or stair/Inner 

Chowk as their locations are common for all floors. 

Floor Name : - Floor name will be taken from text inside floor poly and on same layer. 

  A floor plan is automatically associated/linked by AutoDCR software with one or more floor section 

poly in Section plan. This is done by matching name of Floor Plan and SectionFloor so both must be 

same. 

Typical Floor Non-Typical 

"TYPICAL" X "FLOOR PLAN"X: Floor 

numbers in specific format (, or & or -) 

X "FLOOR PLAN" 

X: Direct Floor's Name 

e.g.: 

TYPICAL 1,2 FLOOR PLAN 

e.g. 

GROUND FLOOR PLAN 



 

 

TYPICAL 1-4 FLOOR PLAN 

TYPICAL 2&3 FLOOR PLAN 

FIRST FLOOR PLAN 

SECOND FLOOR PLAN 

How to draw :- 

                                   

 _GroundLevel 

Description :  

- Draw the Ground level line as open polyline in section .It is used for checking a total building 

height from this line. 

Shortcut Command :  

- GL. 

How to draw : - 



 

 

                                              

_IndFSI 

Description :  

- Draw a IndFSI as a closed polyline ( area key plan line in the submission drg) which is the area 

covered by all the floors. Indusrial building means building or part thereof wherein products or 

material are fabricated , assembled or processed such as assembly plants, laboratories , power plans, 

refineries, gas plants, mills, dairies and factories. This polyline should be excluding balcony & 

terraces area. 

Shortcut Command :  

- IFSI. 

How to draw : - 

                                          



 

 

                                              

_IntRoad 

Description :  

- Draw internal road with text specifying its width as shown in figure. And draw a center line. And 

type of layer of the center line must be center line (Type of the Layer). 

Shortcut Command :  

- R2. 

How to draw : - 

                                        

 _Lift 

Description :  

- Draw a Lift as a closed polyline which is a mechanically guided car, platform or transport for 

persons and materials between two or more levels in a vertical or substantially vertical direction. If 

fire lift are provided then use the marking of “Fire lift" option from Mark -> Lift -> Fire Lift . Fire 

Lift means a special lift designed for the use of fire service personnel in the event of fire or other 

emergency. 



 

 

Shortcut Command :  

- LFT. 

How to draw :  

                                                   

_LocationPlan 

Description :  

- Location plan if any to be drawn on this layer. This is only for reference. No verifications are done 

by AutoDCR for this layer so not compulsory. 

Shortcut Command :  

- LCP. 

 

 _MainRoad 

Description : 

 - Draw a MainRoad as a closed polyline which is abutting the plot. On the site that road is any type 

of road.such as any highway, street , lane, etc. over which the public have a right of passage or access 



 

 

or have passed and had access uninterruptedly for a specified period, whether existing or proposed in 

any scheme. Road name start with its width only. 

Shortcut Command :  

- R1 

How to draw : - 

 

 

                                                 

 _MarginLine 

Description :  

- No need to draw Margin Line, Just use Mark Margin tool for it. This layer is not provided for 

users. AutoDCR uses '_MarginLine' layer for its own internal use. 

 

 _Nala 

Description :  



 

 

 Draw Nala polygon on this layer. 

Shortcut Command :  

- R4. 

How to draw : - 

 

  

 _NETPLOT 

Description :  

- No need to draw NETPLOT. This layer is not provided for users. AutoDCR uses '_NETPLOT ' 

layer for its own internal use. 

 

_OpenSpace 

Description :  

 Draw Open space as closed polyline reserved as recreational space on this layer. With text on same 

layer. 

Shortcut Command:  

- OPS. 



 

 

How to draw : - 

 

_Parking 

Description :  

- Draw a parking poly as a closed polyline which is an enclosed covered or open area sufficient in 

size to park vehicles. This closed polyline shall contain a text on same _Parking layer. This text is 

treated as name of parking. Insert the parking by using a Insert-> Parking option. 

Shortcut Command :  

- PK. 

Parking Name : 

 - This closed polyline shall contain a text on same _Parking layer. This text is treated as name of 

parking. 

  On this layer, you can group and insert any number of parking 



 

 

Parking Name 

Car  CP 

Scooter SC 

Cycle CY 

Visitor's Parking ( Car ) VVP 

Visitor's Parking ( Scooter ) VSP 

Transportation vehicle TV 

Ambulance AMB 

How to draw : - 

 

 

_Passage 

Description :  

- A closed polyline on _Passage represents a passage. It is a common passage or circulation space 

including a common entrance hall. This closed polyline contain a text. This text must be on 

"_Passage" layer. This text is treated as name of closed polyline. 

Centre Line :  

- All Passage poly must contain an Open Polyline inside that closed poly representing centre  line on 

"_Passage" Layer. But line type of center line must be 'Center line'. 



 

 

Shortcut Command :  

- PAS 

How to draw : - 

 

 

 

_Plot 

Description: 

 - Draw a Plot poly as a closed polyline which is a parcel or piece of land enclosed by definite 

boundaries. A Plot will contain all Proposed Works (buildings, wings), open space, Internal Roads, 

Parking etc. The overall Plot Entity represent a Plan, AutoDCR refers it as 'Layout Plan'. The overall 

Plot Entity represent a Plan, AutoDCR refer it as "Layout Plan". 

Shortcut Command:  

PLT 

How to draw :- 



 

 

 

 

_Podium 

Description :  

- Podium shall be drawn on '_Podium' layer as a closed polyline. Podium should be inside plot 

covering proposed works if any. 

Shortcut Command:  

POD. 

How to draw :- 



 

 

 

 

_PropWork 

Description :  

- Proposed Work is a building profile/outline and shall be drawn inside plot. all detail Building plans 

(inside building polyline ) of all PWork( inside plot polyline) is associated/linked automatically by 

Auto-DCR by matching its name. 

  So for proper association it is required to follow specific standard as given. 

  XY (Z) 

  X is Wing name. 

  Y is wing number. 

  Z is Building name. 

For example if there are four wings A1,A2 & B1,B2 in building named "Monarch" then proposed 

work  names shall be - 

  A1 (Monarch), A2 (Monarch) 

  B1 (Monarch), B2 (Monarch) 



 

 

Reference Circle: All PWork poly must contain two circles (of any size) with its center on common 

point for whole building. First on layer of any FSI and second on Layer “_Floor”. These reference 

circles to be inserted from PreDCR -> insert-->Direction ref circles at the same location in all the 

floors as well as pwork in plot.  Usually they can be placed inside either Common Lift or Stair/Inner 

Chowk (because generally their location is same on all floors). Reference circles are used by the 

software for overlapping all floor plans. 

Shortcut Command: 

 PW. 

How to draw :- 

 

 

_RailLine 

Description :  

- Railway line shall be drawn as a non closed polyline with some text indicating gauge of rail line 

over it. 

Shortcut Command :  

- L2. 



 

 

How to draw : - 

 

 

_Ramp 

Description :  

- Draw a Ramp poly as a closed polyline in floor plans and/or plot and section. Naming convention 

for ramp is "---m. long and ---m. high ramp-1". give unique name to each ramp. 

Shortcut Command :  

- RP. 

How to draw : - 

 

 

_RefugeArea 



 

 

Description :  

- Refuse area to be drawn in plan as a closed polyline with text on this layer. Overlapped with FSI 

layer but outside the FSI poly. 

Shortcut Command :  

- RFG. 

How to draw :  

 

 

_ReservArea 

Description :  

- Reserved area ( Reservation area in Development plan) shall be drawn on this layer if present in 

proposal. This can be any area reserved for/by Authority for future. 

Shortcut Command : 

- RSA. 

How to draw :- 



 

 

 

 

_ResiFSI 

Description :  

- Draw a ResiFSI as a closed polyline which is the area covered by a building on all the floors. This 

FSI polyline only used for residential use building or floor. ResiFSI poly must be inside Floor poly. 

Shortcut Command : 

 - MFS 

How to draw : - 

 



 

 

 

_RoadWidening 

Description :  

- Draw a road widening polyline as a closed polyline which the plot area is going to the road, that 

area should be drawn on this layer. It should be inside the plot polyline. 

Shortcut Command : 

 - R5. 

How to draw : - 

 

 

_Room 

Description :  

- A closed polyline on _Room layer represents a room. This closed polyline contain a text. This text 

must be on _Room layer. Room to be marked by assigning them names using Assign Name-> room 

option from PreDCR menu. 



 

 

Shortcut Command :  

- RU. 

How to draw : - 

 

 

_Sanitation 

Description :  

 Draw any sanitation entities on this layer. (E.g. Water closet , Kitchen sink etc..) Mark those entities 

by using PreDCR -> Insert -> Sanitation. 

Shortcut Command :  

- SND. 

 

_Section 

Description :  



 

 

- Draw a Section polyline as a closed poly of section boundary which contain all floors with stair 

cabin, Lift machine room, water tanks etc. as shown in the figure. Also write the name as "Section" in 

this section poly. 

In this closed poly of section draw sections of all floors with stair cabin, inner Chowk, Lift machine 

room, Ventilation shaft, water tanks etc. as shown in the figure. 

Also write the name as "Section" in this section poly. 

This section poly will present inside the building poly. 

Shortcut Command :  

- SEC. 

How to draw : - 

 

 

_SitePlan 

Description :  

 Site plan if any to be drawn on this layer. This is only for reference. No verifications are done by 

AutoDCR for this layer. so not compulsory. 



 

 

Shortcut Command: - STP 

 

_SpecialUseFSI 

Description :   

FSI ploy for all other building uses like educational, institutional etc. except ResiFSI, CommFSI &  

IndFSI use should be drawn on this layer. 

Shortcut Command: - SUF. 

How to draw:  

 

 

 _StairCase 

Description :  

- StairCase: On this layer, Each StairCase poly shall have three lines for Flight Width, Intermediate 

Landing and Floor Landing on same layer. Mark these open polyline by using Mark-> Staircase 

option from PreDCR menu. Also draw in plan all the treads on this layer which is a open polyline. 



 

 

This closed polyline contains a text. This text must be on _Stair layer. This text is treated as name of 

closed polyline. On this layer, Each StairCase poly shall have three lines for Flight Width, 

Intermediate Landing and Floor Landing on same layer This can be mark by tool Mark > StairCase 

> intermediate landing etc. 

Shortcut Command :  

- STR. 

How to draw : - 

 

 

_ SubDivision 

Description : 

 - In Subdivision one plot  is divided into more than one Subdivisions. 

All entities having subdivision as their container entity should be uniquely present in all 

Subdivisions of a Plot i.e. suppose there is a road widening in the Plot then the poly of road 

widening should be different for each Subdivision( subdivided plot). 

Ex. Here Plot 1 is divided into three Subdivisions. And also the Road Widening is divided into 

RoadW 1 and RoadW 2 for each Subdivision.  



 

 

     (for subdivision, draw plot 1 on plot layer and subdivided plots like SubDiv 1,SubDiv 2 &              

SubDiv 3 on sub-division layer overlapping plot 1.) 

Shortcut Command :  

- SBD 

How to draw : - 

 

                                

 

_SubStructure 

Description :  

- Draw various substructures on "_SubStructure" layer as a closed polyline. And mark it according to 

the requirement as Mark -> Substructure -> Society Office, from PreDCR menu. Sub-structures 

can be drawn inside plot or in floor plans. 

Shortcut Command :  

- SSTR. 

How to draw : - 



 

 

 

 

_Tank 

Description :  

- A closed polyline on _Tank layer represents a water tank. Under Ground tank can be drawn in Floor 

or Layout plan. If it is drawn in Floor plan then it should be at bottom of GROUND FLOOR. 

Overhead tank can be drawn in TERRACE FLOOR. Tank should be drawn as per internal size or 

dimensions. Both the tank also draw in section also. 

Tank Name: - This closed polyline contain a text and must be in given format. This can also be done 

by tool Assign Name>Tank 

  Tank Name+ Type +Capacity 

Tank Type Text 

Overhead water tank (O/H) 

Underground water 

tank 

(U/G) 

  For e.g. 

  TANK-1 (O/H) 

  TANK-2 (U/G) 



 

 

Under Ground tank can be drawn in Floor or Layout plan. If it is drawn in Floor plan then it should 

be at bottom of GROUND FLOOR. 

Overhead tank can be drawn in TERRACE FLOOR. Usually it is drawn on StairCase poly in 

TERRACE FLOOR. 

Shortcut Command :  

- TNK. 

How to draw : - 

 

 

_Terrace 

Description:  

- Draw a Terrace as a closed polyline on _Terrace layer which is including parapet wall. 

Terrace can be present in:  

 Plot: It must overlap with PWork 

 Floor: It must be outside the ResiFSI. 



 

 

Shortcut Command :  

- TER. 

How to draw : - 

 

 

 _Void 

Description : 

 - If the space is not Chowk then it can be void. All ducts (where ventilation is not taken) and double 

height rooms can be drawn in void layer. 

Shortcut Command :  

- VD. 

How to draw : - 



 

 

 

 

 

_WaterLine 

Description :  

- Draw a Water line as a open polyline to show Water supply. 

Shortcut Command :  

- WL. 

How to draw : - 

 

 



 

 

_Window 

Description :  

- Window is a closed Polyline Which is drawn on "_Window" layer. Also you can insert a particular 

size poly for Window using Insert->Window from PreDCR menu. 

Shortcut Command :  

- WND. 

How to draw : - 

 

 

_DownComer 

Description :  

- Draw a fire fighting installation Down Comer on this layer as closed poly tentatively in drawing. 

_DryRiser 

Description :  

- Draw a fire fighting installation Dry Riser on this layer as closed poly tentatively in drawing. 



 

 

_FireExtinguisher 

Description :  

- Draw a fire fighting installation FireExtinguisher on this layer as closed poly tentatively in drawing. 

_HoseReel 

Description :  

- Draw a fire fighting installation HoseReel on this layer as closed poly tentatively in drawing. 

_ManualFireAlarm 

Description :  

- Draw a fire fighting installation ManualFireAlarm on this layer as closed poly tentatively in 

drawing. 

_WetRiser 

Description :  

- Draw a fire fighting installation WetRiser on this layer as closed poly tentatively in drawing. 

_YardHydrant 

Description :  

- Draw a fire fighting installation YardHydrant on this layer as closed poly tentatively in drawing. 

 

 

 

 



 

 

Commands 

Create New Project (PDCRNWP):  

This command will Create New project for current drawing. 

Here you have to select Type of Project as  

 Proposed Development. 

 

Note: It is always compulsory to add your drawing to new Project. 

 

 

Create AutoDCR Layers (PDCRCL):  

This command will create layers required for AutoDCR and as per the Project Type you have 

selected. 

Fix Poly (PDCRPE):  

 

Use this command once on the final drawing which will process all the polyline on the PreDCR 

layer and remove extra vertices found on polyline. This command can be used before verifying 

the drawing using Verify commands. 

 



 

 

Verify Drawing:  

 

This command will verify the current drawing as required by DCR specifications. 

 a) Verify Close Entities (PDCRVD): Verify that LWPOLYLINE entities on the selected layers are 

closed and contain one text . 

 

b) Verify All drawing (PDCRVT): Use this command to verify the layout and building level 

objects in the current drawing plan.  

Major checks are as follows: 



 

 

 

In the "Verify All Drawing Dialog" you can select the layout or building objects to be checked. 

Then to view the result press OK button. PreDCR will start checking all corresponding objects in 

the currently open drawing and then display the status as OK or list of failed objects in the dialog 

as shown in Figure. Failed Object Information.  

Check if these entities are drawn as closed LWPOLYLINE. 

Name text is given to all objects. 

Entities are placed exactly inside their parent objects (container). 

Naming conventions are followed properly. 

c) Objection List (PDCROLST): This command gives the list of all minimum required entities 

which are not there in your drawing. If all required entities found then it gives a message that 

“minimum required entities are present in drawing”. 

 

 Markings 

 

Marking adds some extra meaning in entity. Following commands are provided to mark different   

entities as per requirement.  

Mark-> Stair Case-> Fab /Spiral Staircase (PDCRSCFAB): Mark line inside staircase as a 

Fabricated or spiral staircase.  

Mark->Stair Case->     Mark Intermediate Landing (PDCRMIL): Mark line inside staircase as 



 

 

intermediate Landing.  

Mark->Stair Case Landing->Flight Width (PDCRMFW): Mark line inside staircase as Flight Width. 

Mark->Stair Case Landing->Floor Landing (PDCRMFL): Mark line inside staircase as Floor 

Landing.  

Mark-> Lift-> (PDCRSCES): mark Lift as a  Lift  

Mark->Passage->: Mark passage as a Common Passage 

Mark->FSI-> Existing FSI (PDCRCONES): Mark Residential or Commercial FSI as Existing FSI. 

Mark->FSI->Normal (Default) (PDCRUMFSI): Mark Residential or Commercial FSI as Normal FSI. 

Mark->FSI Surrender to Rajsthan -> Hospital (PDCRMSPLTT): mark-> Hospital 

 Mark->FSI Surrender to Rajsthan -> Parking Area (PDCRMSPLTT): mark-> parking area 

Mark->Carpet Area->Splitted Tenement (PDCRMSPLTT): Mark Carpet Area as Splitted tenement. 

Mark->Carpet Area-> Normal (Default) (PDCRUMFSI): Mark Residential or Commercial Carpet 

Area as Normal Carpet Area. 

Mark->Projection-- > 

Mark->Projection->Otta/Steps (PDCRMVPROJ): Mark Projection as Garbage shaft. 

Mark->Projection->F.Bed (PDCRMBPROJ): Mark Projection as Flower Bed. 

Mark->Projection->Chhajja/Cornice/Whether shade (PDCRMCJPROJ): Mark Projection as 

Chhajja/Cornice/Whether shade. 

Mark->Projection->Canopy (PDCRMCBPROJ): Mark Projection as Canopy. 

Mark->Projection->Loft (PDCRMLPROJ): Mark Projection as Loft in floor plan as well as in 

section. 

Mark->Projection->Porch (PDCRMCPROJ): Mark Projection as Canopy. 

Mark->Projection->Archi. Projection Normal (Default) (PDCRUMPROJ): Mark Projection as 

Normal Architectural projection. 

 

Mark->Existing Structure ->To Be Retained  (PDCRMREXWD): Mark Existing structure as to be 

Retained . 

Mark->Existing Structure-> To be demolish (Default) (PDCRMRMREXWC): Mark Existing 

structure as to be Demolish. 

Mark->SubStructure-> ELECTRIC ROOM (PDCRMER): Mark Sub Structure as a ELECTRIC ROOM. 

Mark->SubStructure->Transformer-> (PDCRMTRAN): Mark Sub Structure as a Transformer 



 

 

Mark->SubStructure->WATCHMAN ROOM (PDCRMWMC): Mark Sub Structure as a WATCHMAN 

ROOM. 

Mark->SubStructure->SOCIETY OFFICE ROOM (PDCRMOR): Mark Sub Structure as a Society office. 

Mark->SubStructure->Servant Quarter (PDCRMSQ): Mark Sub Structure as a servant quarter. 

Mark->SubStructure->Sanitary Block (PDCRMSB): Mark Sub Structure as a sanitary block. 

Mark->SubStructure -> Garage (PDCRMGRJ): Mark Sub Structure as a  garage when garage is 

covered. 

Mark->SubStructure ->Effluent Treatment Plant (PDCRMETP): Mark Sub Structure as a Effluent 

Treatment Plant. 

Mark->SubStructure ->Out House (PDCRMSPT): Mark Sub Structure as a Out House. 

Mark->SubStructure ->Pump House (PDCRMPR): Mark Sub Structure as a Pump House  

Mark->SubStructure ->Septik Tank / Soak pit (PDCRMSPT): Mark Sub Structure as a Septik Tank. 

Mark->SubStructure -> WASTE WATER TREATMENT PLANT: Mark Sub Structure as a WASTE WATER 

TREATMENT PLANT. 

Mark->SubStructure -> LIBRARY: Mark Sub Structure as a LIBRARY. 

Mark->SubStructure -> COMMUNITY HALL: Mark Sub Structure as a COMMUNITY HALL. 

Mark->SubStructure -> COMMON STORE ROOM: Mark Sub Structure as a COMMON STORE ROOM. 

Mark->SubStructure -> COMMON TOILET: Mark Sub Structure as a COMMON TOILET. 

Mark->SubStructure -> SOLAR POWER PLANT: Mark Sub Structure as a SOLAR POWER PLANT. 

Mark->SubStructure -> DUB: Mark Sub Structure as a DUB. 

Mark->SubStructure -> ELECTRIC SUB-STATION: Mark Sub Structure as a ELECTRIC SUB-STATION. 

Mark->SubStructure -> SEWAGE TREATMENT PLANT: Mark Sub Structure as a SEWAGE TREATMENT 

PLANT. 

Mark->SubStructure -> RAIN WATER HARVESTING: Mark Sub Structure as a RAIN WATER 

HARVESTING. 

Mark->SubStructure -> A C PLANT ROOM: Mark Sub Structure as a A C PLANT ROOM. 

Mark->SubStructure -> AHU: Mark Sub Structure as a AHU. 

Mark->SubStructure -> SWIMMING POOL: Mark Sub Structure as a SWIMMING POOL. 

Mark->SubStructure -> PUMP HOUSE: Mark Sub Structure as a PUMP HOUSE. 

Mark->SubStructure -> DISH ANTENNA ROOM: Mark Sub Structure as a DISH ANTENNA ROOM. 

Mark->SubStructure -> VIDEO ROOM: Mark Sub Structure as a VIDEO ROOM. 



 

 

Mark->SubStructure -> WELL: Mark Sub Structure as a WELL. 

Mark->SubStructure -> TELEPHONE INSTALLATION PLANT/STP: Mark Sub Structure as a TELEPHONE 

INSTALLATION PLANT/STP. 

Mark->SubStructure -> ENTRANCE GATE: Mark Sub Structure as a ENTRANCE GATE. 

Mark->SubStructure -> FITNESS CENTER: Mark Sub Structure as a FITNESS CENTER. 

Mark->SubStructure -> SUCTION TANK: Mark Sub Structure as a SUCTION TANK. 

Mark->SubStructure -> GYMNASIUM: Mark Sub Structure as a GYMNASIUM. 

Mark->SubStructure -> CLUB- HOUSE: Mark Sub Structure as a CLUB- HOUSE. 

Mark->SubStructure -> DUST BIN: Mark Sub Structure as a DUST BIN. 

Mark->SubStructure -> MILK/TELEPHONE BOOTH: Mark Sub Structure as a MILK/TELEPHONE BOOTH. 

Mark->SubStructure -> LETTER BOX: Mark Sub Structure as a LETTER BOX. 

Mark->SubStructure -> IND.CHIMNEY: Mark Sub Structure as a IND.CHIMNEY. 

Mark->SubStructure -> PARKING SHADE: Mark Sub Structure as a PARKING SHADE. 

 

 

Mark->Margin (PDCRMRGN): Use this command to define or mark the front, sides and rear 

margins of the plot. . 

 

 

 

Insert entities 

Insert->Parking-> Car ( (PDCRICP) -> Use this command to insert car-parking poly of . at 

selected point.  



 

 

Insert-> Parking-> Scooter (PDCRISP) ->Use this command to insert Scooter parking poly at 

selected point. 

Insert-> Parking-> Cycle (PDCRICY) ->Use this command to insert Cycle parking poly at selected 

point. 

Insert->Parking-> Loading unloading   (PDCRITV) ->Use this command to insert parking Loading 

unloading   poly at selected point. 

Insert->Parking->Visitors Parking->Car (PDCRIVP) -> Use this command to insert visitor car 

parking poly  at selected point 

Insert->Parking->Visitors Parking->Scooter (PDCRIVSP) -> Use this command to insert visitor 

Scooter parking poly at selected point 

Insert->Parking->Ambulance-> Use this command to insert Ambulance parking poly at selected 

point 

Insert->Door (PDCRIDRNAM): Use this command to insert door poly at selected point and with 

specified size given by user. As soon as you use this command the following Dialog appears.   

           

Insert->Window (PDCRIWNDNAM): Use this command to insert window poly at selected point 

and with specified size given by user. 



 

 

 

Insert-> Text (PDCRIWC): Use this command to insert sanitation text at selected point. Ex.  Water 

closet ,  Urinal , Wash basin etc. which is mark on  then insert text by using sanitation text 

marking from insert menu. 

Insert->Direction Reference Circle (PDCRIWC): Use this command to insert direction reference 

circle. Insert this circles in all the floor plans as well as in proposed work at the same & common 

place (e.g. Lift or Stair) of all the floors. 

Insert -> Tree: Use this to insert Tree. Insert Trees showing location of Trees in your plot.  

Insert->North Direction: Use this to insert North Direction. Insert North Direction indicating the 

sides of your plot. You have to rotate this as per North Side.  

 

 

Assign Name 

- There are few naming conventions required by AutoDCR, for which PreDCR provides the 

following tools: 

Assign Name->Building and proposed works (PDCRBLDPWNL): Use this command to give name 

for building poly and its associated proposed works. 



 

 

 

Assign Name->Tank (PDCRTNKNAM): Use this command to give name for Tank poly and its 

corresponding tanks. 

 

Fill in the dialog and select the tank poly drawn in plan and the same drawn in section 

Assign Name->Room (PDCRASRUN): Use this command to give different names for Room poly. 

          

 



 

 

Assign Name->Floor Name  (PDCRASFLRNAM): Use this command for assigning name to a floor 

poly and it’s corresponding  floor in section poly in section. 

 

 

Tools  

All/Remover Tool Tip (PDCRTOOLTIP): 

This command will activate the tool tips for PreDCR layers. 

Show Only DCR Layers: 

All PreDCR layers (PDCRSPL): 

This command will turn off all the layers in the drawing except PreDCR layers.  

Building level layer (PDCRSBL): 

 This command will turn on all the building plan level layers in the drawing. 

Layout level layer (PDCRSLL):This command will turn on all the Layout plan level layers in the 

drawing. 

Show Only DCR Layers (PDCRSDL): 

This command will turn off all the layers in the drawing except DCR layers.  

  

Show Other Layers (PDCRSOL): 

This command will turn off all the DCR and PreDCR layers in the drawing. 

 



 

 

Show all layers (PDCRSAL); 

 This command will turn on all layers in the drawing. 

 

Calculate Total Area (PDCRCTA): 

This command will compute the total area of all selected closed polygons. 

 

 

Calculate Deducted Area (PDCRCDA): 

This command will compute the area of closed polygon after deducting closed polygons found 

inside. 

           

Get All Inside Poly (PDCRFIP):  

This command will highlight all polygons, which found exactly inside selected polygon under 

test. 

  

Get All Overlapping Poly (PDCRGOP): 

This command will highlight all polygons, which are overlapping with selected polygon under 

test. 

  

Get All Intersecting Poly (PDCRGIP): 



 

 

This command will highlight all polygons, which are intersecting with selected polygon under 

test. 

  

Find Open Entities (PDCRFNDO): Highlight open entities on PreDCR layers. 

 

Find Closed Entities (PDCRFNDC): Highlight closed entities on PreDCR layer. 

 

Shortest distance (PDCRFSD):  

This command will find the shortest distance between two entities. 

 

Spelling check (_spell): This tool is used for spelling checking. 

 

Find Object (PDCRFOBJ): This command zoom & highlight object of a given handle. 

 

Set Default ACAD Version ( PDCRSDA ): 

 

 

PREDCR SHORT-CUT COMMANDS 

Layer name Description 
 

Naming Convention Short 
command 

_Amalgamation Draw a continuous poly around the 

plots you want to amalgamate. 

Amalgamation contains more than 

one plot amalgamated together. 

All entities having amalgamation as 

their container entity should be 

uniquely present in each 

amalgamation. 

I.e. suppose there is a road 

widening in the Plot then the poly 

of road widening should be 

 AMLG 



 

 

different for each amalgamation. 

(For amalgamation, draw plot 1, 

plot 2, plot 3 on plot layer and 

amalgamated plot AmalPlot 1, on 

amalgamation layer overlapping 

plot 1.) 

_Amenity Draw Amenity space as a closed 

polyline which is reserve for 

utilities, services and conveniences. 

 

 AMN 

_ArchProj This layer is used to represent 

various Architectural Projections in 

your Plan. Draw a closed Polyline 

for Architectural Projections. And 

mark it using Mark->Projection 

from PreDCR menu, according to 

requirements. Canopy/porch will 

come in plot & other projections 

will come with floor plans. 

 

Mark -> Projections -> 

Chajja 

 

AP 

_Balcony Draw a balcony as a closed polyline 

which is a horizontal projection 

including parapet to serve as a 

sitting out place. Name of balcony 

must be inside and on _Balcony 

layer. 

 

 

Mark> Balcony >    

Enclosed Balcony  or 

Unmark (default) 

 

BL 

_Building Building is used to group all floor 

plans of the same building.   Draw a 

closed poly enclosing all the floor 

plans and section of the same 

 

Naming Convention 

will be  

provided by 

BLD 



 

 

building on _Building layer. Note: As 

written above, dimension or area 

of this building poly has no 

meaning in AutoDCR. This is just 

an logical group of all floors of the 

same building. If the building plans 

of multiple PWorks or wings are 

same then building name shall be 

as given aside. 

 

Tool>Assign Name 

A (Bldg.Name) inside 

Bldg.Poly & 

A-1 (Bldg.Name) inside 

Pwork Poly 

 

_CarpetFSI 

Draw carpet area as a closed 

polyline which is a net usable floor 

area within a building excluding 

that covered by the walls or any 

other areas specifically exempted 

from floor space index computation 

in these regulations. 

 

If Carpet is Splitted – 

Tenement. 

Mark-> CarpetArea-> 

normal (default) 

 

CPT 

 _Chowk Draw a chowk as a closed polyline 

which is an enclosed space 

permanently open to the sky 

within a building at any level. From 

chowk we take ventilation for 

habitual rooms 

 CWK 

_CommFSI Draw a CommFSI as a closed 

polyline which is the area covered 

by a building on all the floors. This 

FSI polyline mainly used for 

commercial use bldg. 

 

 

No need to give name 

on this layer. 

CMFS 



 

 

_CompoundWall Closed polyline of compound wall 

to be drawn on this layer 

overlapping plot.  

 

 

1.5m high compound 

wall 

CW 

_DPRoad Description: - Draw a DP Road as 

a closed poly line with Text. (eg : 

any DProad passing from inside of 

the plot)(Note: Road width must be 

written at the starting of Text). 

 R7 

_Door Door is a closed Polyline Which is 

drawn on “_Door” layer. Also you 

can insert a particular size poly for 

Door using Insert->Door from 

PreDCR menu. 

 

 

Insert-> Door 

DR 

_SewageLine Sewage Line shall be drawn as a 

open polyline on this layer. 

 L5 

_Electline 

 

 

 

 

Electric line will be present in the 

layout plan and shall pass through 

plot entity as a non closed polyline. 

   Name electric line shall start with 

its voltage capacity and text 

insertion point shall lie on its 

polyline. 

 

 

33 KV High Tension 

Line 

L1 

_ExStructure Draw a Exstructure as a closed 

polyline which is a building or 

structure existing authorized 

before the commencement of these 

regulation. And mark it using Mark 

 

Mark-> Existing 

Structure-> To be 

Demolished    OR   

To be Retained       

ES 



 

 

-> Existing structure as 'To be 

demolished' or 'To be retained’. 

 

_Floor Floor poly should be drawn as a 

closed Polyline with Text on same 

Layer. This is just a logical Group of 

all floor Entities. 

           Floor Name: Floor Plan will be 

automatically link with Section by 

matching the Floor Name. Hence all 

names to be given using <Assign 

Name> function 

Naming Convention 

will be  

provided by 

Tool>Assign 

Name>Floor name 

 

Name of  floor should 

be in given format: 

TYPICAL-1,4 FLOOR 

PLAN 

TYPICAL-1-5 FLOOR 

PLAN 

TYPICAL-2&3 FLOOR 

PLAN 

Ground Floor Plan 

FLR 

_GroundLevel The Ground level line should be 

drawn as an open polyline in the 

section poly. 

Prop.Ht. will be considered from 

GroundLvl Polyline 

 

 

No need to give name 

on this layer. 

 

 

GL 

_IndFSI Draw a closed FSI Polyline, which is 

used as a Industrial Purpose. 

 

No need to give name 

on this layer. 

IFSI 

_IntRoad 

 

Draw each Internal Road as a 

closed Polyline with Centre Line 

(Ltype-CentreLine) & single text 

 

7.50 m wd. Internal 

Road 

R2 



 

 

inside it. 

 

_Lift 

 

Draw a Lift as a closed polyline 

which is a mechanically guided car, 

platform or transport for persons 

and materials between two or more 

levels in a vertical or substantially 

vertical direction 

 Fire Lift means a special lift 

designed for the use of fire service 

personnel in the event of fire or 

other emergency. 

 

Naming Convention 

will be  

provided by 

Tool<Mark>Lift 

 

 

 

LFT 

_Locationplan 

 

Location plans if any to be drawn 

on this layer. This is only for 

reference. No verifications are done 

by AutoDCR for this layer so not 

compulsory. 

 

 LCP 

_Marginline Margin Polylines will be created by 

PreDCR by using Tool 

"Mark>Margins" 

(User need not do anything on this 

layer.) 

 

 L3 

_MainRoad 

 

 

Draw Main Road as a closed Poly 

with Text, which should be abutting 

with the Plot closed Poly. 

(Note: Road width must be written 

at the starting of Text) 

 

24.00 m wd. Main 

Road 

R1 



 

 

_Nala Draw centre Line of Nala as an 

open Polyline on this layer. Name of 

the poly should contain width of 

the Nala 

 

 R4 

_NetPlot No need to draw NETPLOT. This 

layer is not provided for PreDCR 

users.. 

No need to give text on 

this layer. 

 

NPLT 

 

_OpenSpace Draw Open space as closed polyline 

reserved as recreational space on 

this layer. With text on same layer. 

  

OPS 

_Parking Draw a closed Polyline for Parking 

on “_Parking” Layer. You can also 

use Insert function to insert 

desired Parking Poly in your 

drawing. 

 

 

Insert-> Parking->Car-

/ Scooter/ cycle / 

/Loading/unloading 

space/ Visitor Parking  

PK 

_Passage 

 

 

Draw a closed polyline on 

“_Passage” Layer to represent 

passage with Centre Line (Ltype-

CentreLine) & single text inside it. 

 

(Note: If Premium for Passage is 

going to be Paid, Passage should be 

marked by using Tool "Mark " 

 

 

Mark > Passage  

 

 

 

 

 

PAS 

_Plot Draw a Plot poly as a closed 

polyline which is a parcel or piece 

of land enclosed by definite 

boundaries.A Plot will contain all 

 

 

PLT 



 

 

Proposed Works (buildings, wings), 

open space, Internal Roads, 

Parking etc. The overall Plot Entity 

represent a Plan, AutoDCR refer it 

as "Layout Plan". 

 

_Podium Draw a closed polyline on 

“_Podium“ to represent Podium. It 

should be shown in the layout and 

not in floor plans 

 

 

 

POD 

_PropWork PWork is a building profile and 

shall be drawn inside plot. Draw a 

closed polyline for Proposed Work 

on “_PropWork” Layer. 

 

 

Tools > Assign Name >  

Building and 

PropWork. 

PW 

_PropAccessRoad Draw the road which is proposed 

as right of way by the user on this 

layer. It is similar to internal road 

except that the margins required 

will be same as front margins. 

 R8 

_RailLine Railway line shall be drawn in the 

layout plan as a Open Poly & Text 

which insertion point lies on the 

Polyline. 

(Note: Railway Gauge must be 

written at a starting of Text) 

 

 

_ Meter Gauge Railway 

Line 

L2 

_Ramp Draw a Ramp as a closed polyline  SECR 



 

 

 with Centreline (L-type-Centre) & 

Text inside it in Plan. 

 

10.0m long 1.5m high 

Ramp 

_RefugeArea 

 

A closed polyline with Text around 

the refuge area should be drawn on 

same Layer. 

Refuge area should be outside 

overlapped with FSI (ResiFSI, 

CommFSI) poly. 

 

 RFG 

_ResiFSI Draw a ResiFSI as a closed polyline 

which is the area covered by a 

building on all the floors. This FSI 

polyline only  used for residential 

use bldg or floor. 

 

No need to give text on 

this layer. 

MFS 

_ReservArea If there in any Reservation Area in 

Plot, it should be drawn as a closed 

Polyline with Text inside same 

Layer. 

 RSA 

_Road Widening Road Acquisition/Road Widening 

area shall be drawn as a closed 

Polyline with Text on same layer 

inside Plot Entity. Margin will be 

generated & checked from 

Roadwidening Poly by AutoDCR 

software. 

 R5 

_Room A closed polyline for each room 

with its text inside should be drawn 

on this layer. Text should be given 

using <Assign Name> function 

 

 

Assign Name > Room 

RU 



 

 

_Section Section poly should be drawn as a 

closed Polyline with Text on same 

Layer. It is used to group all 

Sectional detail like SectionFloor, 

Plinth, Stair cabin , Tank etc. 

(This is just a logical Group of 

Sectional Entity).  

(Note: Area or size of Floor doesn't 

have any meaning in AutoDCR) 

 SEC 

_SectionFloor Draw a SectionFloor as a closed 

polyline which is the height of that 

floor (slab top to slab top) This poly 

only used for checking floor height. 

For assigning the name of 

SectionFloor use Assigned name 

option from PreDCR tool menu. 

Name of each section floor will be 

same as of floor in plan. 

  For one typical floor plan multiple 

floor section will be there. 

For e.g. for one typical floor plan for 

1-3 floors there will three sections 

shall be drawn with name "First 

Floor Plan", "Second Floor Plan" and 

"Third Floor Plan" respectively. 

 SECF 

_SitePlan 

 

The encapsulating poly around the 

Site/Key Plan with the Text & Scale 

inside it.  

 

 

 

STP 



 

 

_StairCase Total Staircase area should be 

drawn as a closed polyline with text 

inside it. 

This Main Stair Poly should contain 

Intermediate Landing, Floor 

Landing & Each Tread as an open 

polyline. 

Intermediate & Floor Landing Poly 

can be Marked by PreDCR Tool 

"Mark>Staircase>Int. or Floor 

Landing" 

(Note: If Premium for Staircase is 

going to be Paid, Staircase should 

be marked by using Tool 

"Mark>Staircase>Free from FSI" 

 

Mark-> Stair Case-> 

Fire Escape Staircase 

OR Fab/Spiral Stair 

 

Mark-> Staircase  

Intermediate Landing-

> Flight Width > Floor 

Landing 

STR 

_SpecialUseFSI A closed poly represents a other 

than Residential , commercial or 

Industrial use FSI or Floor FSI.  

It will cover whole area which is 

considered in FSI Area per Floor. 

 SUF 

_SubDivision In Subdivision one plot  is divided 

into more than one Subdivisions. 

All entities having subdivision as 

their container entity should be 

uniquely present in all Subdivisions 

of a Plot i.e. suppose there is a road 

widening in the Plot then the poly of 

road widening should be different for 

each Subdivision ( subdivided plot). 

 SBD 



 

 

_SubStructure SubStructures which are allowed in 

Margins or Layout & Free from FSI 

should be drawn as a closed 

polyline with text inside it. 

Name of the 

SubStructure can be 

assigned from 

Mark>SubStructure 

tool. 

SSTR 

_Tank Tank clear size should be drawn as 

a closed Polyline with Text on this 

Layer in Floor Plan or Plot as well 

as Section with same Text. 

(Note: It should be in proper 

Naming convention which is 

Provide by Predcr by using Tool. 

Assign Name>Tank   TNK 

_Terrace Closed polylines around the 

terraces to be drawn on this layer. If 

the terrace is used commonly by all 

tenements mark it as Common 

Terrace else it will be treated as 

Individual by default. 

 TER 

_VShaft Draw Ventilation shaft/duct area as 

a closed Polyline with Text. Inside 

FSIArea on _VShaft Layer. Only 

those shafts from which ventilation 

for habitable room is not taken 

should be drawn on this layer. 

 

 

AVS 

_Void If the space is not Chowk then it can 

be void. All ducts (where ventilation 

is not taken) and double height 

rooms can be drawn in void layer. 

 VD 

_Waterline Draw a open polyline on 

“_Waterline” to represent water 

 L4 



 

 

lines. 

_Window Draw a closed polyline on 

_Window” Layer to represent 

window. You can also use Insert tool 

to insert window poly for particular 

size. 

Insert > window WND 

 

Specifications to be followed-  

The drawing entities should be drawn on Automatic layers created by using PreDCR. 

Plot layout, detailed floor plan and building section for all the floors should be there in one 

AutoCAD drawing file.   

All building items like proposed plot, proposed work, proposed parking etc must be drawn using 

closed polyline. 

(i.e. Every entity must be closed LWPOLYLINE except Railway Line , Drain line, Water Line, 

Electric Line, Dead Wall and Ground level.).  

Building Sub-Items must be exactly inside of outer closed polygon as per their place 

in architectural plan. 

This means none of the edge or vertex of inside entity should be drawn outside its container 

entity. For example Parking or Open Space poly must be exactly inside the main plot poly. Tools 

are provided in PreDCR to verify this check.  

Every Building Sub-Items should be given a specific/unique name (Text or MText entity) on the 

same layer & inside the entity poly. As far as possible, this name should be unique. If name not 

found then AutoDCR will generate the name automatically. Naming Conventions should be 

followed properly. 

e.g.  Each Room should be given the concerned name Using <Assign Name> function of PreDCR 

Living, Kitchen, Bedroom. Etc. Floor Name: GROUND FLOOR; TYPICAL FLOOR 1,2 & 5-8; 

TERRACE FLOOR. Floor Items: Room Names should be given properly without using 

abbreviations so the software can identify perfect entity. This can be done by Assign name facility 

provided by the software. 

User shall use only following kind of entities for Building Items :-  



 

 

LWPOLYLINE / TEXT / MTEXT 

If in a plan two proposed work are mirrored in that case user should provide two separate 

building plan for each proposed work. 

 

Sample cases 

 

Residential Bldg (Row house) 

 

 

 Residential bldg. (Single Detached with two buildings) 

 



 

 

 

Commercial building 

 

 

 Industrial Building 



 

 

 

Special building ( School bldg) 

 

 



 

 

Meaning of various PreDCR Messages 

Entity contain more than one text"  

      It means Entity on this layer contain more than one text. So remove the extra text. PreDCR 

need only one text for one entity. 

 

"Entity not contain any text"  

       It means This entity not having any name/text, so give the name to this   entity on this layer 

 

"Polyline is not in a proper format"  

        It means Highlighted polyline not drawn properly. So redraw that polyline & check the 

properties of that polyline. 

"Entity is not closed"  

       It means the highlighted entities not a closed polyline so close it by using 'pedit' command. 

 

"Entity is supposed to inside one of the following entities"  

       It means this highlighted entity should be present inside the one of the entities present in the 

given list“ 

 

"Entity is supposed to touching one of the following entities"  

      It means this highlighted entity is supposed to be touched one of the entities in given list 

 

"Entity should be outside overlapped with following entities“ 

      It means the highlighted entity should be outside overlapped with one of the th entities in the 

given list. 

Entity must contain one of following entities“ 

      It means any one layer should be present  inside in this entity which is listed. 

 

Following subentities are not found inside :  

     Direction Ref Point on layer _Floor, 

    Type :BLOCK, Color :ByLayer Status : 



 

 

    Common Point on layer _ResiFSI, 

    Type :BLOCK, Color :ByLayer Status : 

    It means insert the direction reference circles in side of that entities. 

 

"The corresponding Building not found with same name"  

     It means that proposed work not having building with same name. So assigned that building 

with having same name of proposed work. 

"Mark Substructures using PreDCR mark Substructure tool"   

        It means mark the substructure by using mark -> Substructure menu.  Do not type 

substructure name manually. 

 

"The lift machine room not found in building"  

        It means lift machine room having name not same in Plan & in section. 

 

"The lift poly is not suppose to be touch lift machine room"  

        It means Lift machine room should be touch to lift poly in the section. 

 

 ‘Invalid objects, Please Try again"  

        It means If user marking balcony as a enclosed   but selecting layer of terrace then this 

message are getting. If selected entity is incorrect then invalid objects message are showing. So 

select correct layer for particular of that layer marking only 

"Section not found"  

      It means If all the floor plans are drawn but one of them in section floor are missing to 

converting floor in section layer then this message are getting. So draw all the floor plans with 

floor in sections. 

 

"The corresponding entities not found in section"  

      It means that listed entities not present in the section so show that entities in the section. 

 

"The corresponding entities not found in floor"  

      It means that listed entities not present in the floor so show that entities in the floor plan. 



 

 

 

“Two Tanks should not have same Name” 

      It means that two tanks not having a same name. So assigned two tank by using Assigned 

name PreDCR menu. 

 

 

Section 4 

BIMDCR model checker utility 

 

1 INTRODUCTION 

 

This document provides the set of guidelines to create 3D BIM model compliant to BIMDCR 

Software, using REVIT 2017. 

 

BIMDCR Model Checker is an intelligent tool developed to detect modeling errors generated 

during drafting 3D BIM Model, which are not addressed by Revit 2017.  

 

 

 

 

 

 

 

 

 

 



 

 

 

2 GETTING STARTED 

2.1 PRE-REQUISITES 

 

a. Construction template should be used to create the model. 

 

 

 

b. How to start with the drawing 



 

 

 

User should start drawing the plot first and then the model by keeping Survey point 

and base point as zero as shown above. 

 

 

 

c. Parametric revit families should be used to draw any object in the model. 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

d. Structural column should be used to create column objects in the model 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

 

e. Use of room separator along the column and walls to create room object 

should be avoided.  

 

 

f. Material of the wall should be changed by editing its property and not by 

providing a new wall alongside the original wall. 

 

 

 

 

 

 



 

 

 

 

 

g. Stair by component option should be used to draw the stairs. 
 

 

 

h. User should avoid using model group to create any objects. 
 

 

i. Rooms should be marked at each level and tagged accordingly. 
 

 

 

 

 

 

 

 

 

 

 



 

 

 

3 STEPS TO RUN BIMDCR Model Checker 

 

3.1 LOAD BIMDCR FAMILIES 

 

Steps:- 

1. Go to Add-Ins -> Click on prerequisite -> Click on Load BIMDCR families 

 

 

2. Along with BIMDCR lines, BIMDCR parking families will also be loaded into the 

project 

a. User should click on component button to load the BIMDCR families into the project. 
 

b. User should select the parking from the list available 
 

c. User should use these families to draw parking in model. 

 

 
 
 

3.2 PLOT 



 

 

 

 



 

 

 

 

 



 

 

 

 

Note:- 

BIMDCR families should be loaded to draw the plot lines.  

 
 
 
 
 
 

3.3 ROAD 

 



 

 

 

 

Tolerance of  0.01 m is allowed between plot line and the road line. 



 

 

 

Steps:- 

1. Click on 

Architecture. 

2. Then click on 

Model lines. 

3. Select 

BIMDCR road lines from the list. 

4. Draw road 

using different line tools. 

5. After drawing 

the road lines click on Aligned dimension tab to provide the dimensions. 

6. On selecting 

the aligned dimension tool click on the road lines to set the dimension. 

 

 

 

 

 



 

 

3.4 BUILDING AND ANCILLARY BLOCK 

Steps 

1. Go to Add-In -> Prerequisite -> Select Load BIMDCR Marking Lines 

 

 

 

 

 

 

 

 

 

 

2. Go to Architecture -> Model Lines -> Line Style -> Select ’BIMDCR – ‘Building Block’. 

 

 

 

 

 

 

 

 

 

 



 

 

3. Go to Architecture -> Model Lines -> Line Style -> Select ’BIMDCR – ‘Ancillary Block’. 

 

Correct and Incorrect Method of Drawing 

 



 

 

 
 
 
 
 

3.5 ORGANIZED OPEN SPACE/RECREATION GROUND 

Steps:- 

1. Go to Architecture -> Click on model lines. 

 

 

2. Click on BIMDCR-Recreational ground lines 

 



 

 

 

 

 

 

3. Draw Recreational area on the ground floor using BIMDCR – recreational ground 

lines in a closed loop. 

  

3.6 GREEN COVERAGE 

 

Steps:- 



 

 

1. Go to Architecture -> Click on model lines. 

 

 

2. Click on BIMDCR-Green coverage lines. 

3. Draw Green Coverage area on the ground floor using BIMDCR – Green coverage 

lines in a closed loop. 



 

 

 

 

 

 

3.7 KHARAB LAND 

Steps:- 

1. Go to Architecture -> Click on model lines. 



 

 

 

2. Select Kharab land BIMDCR Line 

 

 

 

 

3. Draw Kharab land area on the ground floor using BIMDCR – Kharab lines in a closed 

loop. 

 

 

 



 

 

3.8 AMENITY AREA 

 
 

Steps:- 

1. Go to Architecture -> Click on model lines. 

 

 

 

2. Click on BIMDCR-Amenity. 



 

 

 

3. Draw Amenity area on the ground floor using BIMDCR – Amenity lines in a closed 

loop. 

 

 
 
 

3.9 NALA AREA 

 
 
Steps:- 

1. Go to Architecture -> Click on model lines. 

 

 



 

 

2. Click on BIMDCR-Nala lines. 

 

 

3. Draw Nala land area on the ground floor using BIMDCR – Nala lines in a closed loop. 

 

 



 

 

3.10  MORTGAGE AREA 

 
 

Steps:- 

1. Go to Architecture -> Click on model lines. 

 

 

 

2. Click on BIMDCR-Mortgage lines 



 

 

3. Draw mortgage using BIMDCR – Mortgage lines in a closed loop. 

  

 
 
 
 

3.11  ECONOMICALLY WEAKER SECTION 

 

Steps:- 

1. Go to Architecture -> Click on model lines. 

 



 

 

2. Click on BIMDCR-Economic weaker section lines. 

 

 

 

 

3. Draw Economic weaker section area on the using BIMDCR – Economic weaker 

section lines in a closed loop. 

 

 

 



 

 

3.12  MARK FLOOR 

 
 

Steps:- 

1. Click on Add-Ins -> Markings -> Mark Floor. 

 

 

 

 

2. Click on select building and then click on category to select the category of the floor 

from the list. 

 

 



 

 

3. Select floor from the available floor list that needs to be mapped to the floor from 

the category list and click on add button 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 
 
 
 
 
 
 



 

 

3.13  SELECT BUILDING USE 

 
Steps:- 

1. Click on Add –Ins-> Building details -> Select Use. 

 

  
 

2. Select the use and click on save. 
 



 

 

3.14 CHECK MODEL FOR ERRORS 

 

Steps:- 

1. Select the 3D model view  ->  click on Add-Ins -> Check model 

 

2. Click ok 

 

 
 



 

 

 

3.15  MARK HABITABLE UNITS 

 

Steps:- 

1. Click on Add-Ins -> Markings -> Mark habitable unit. 

 

 

 

 

2. Select the rooms and click finish. 

 



 

 

 

 

3. Flat/Habitable unit will be created. 

 



 

 

 

 

3.16  MARK HABITABLE ROOM / DWELLING UNIT 

 

Steps:- 

1. Click on Add-Ins -> Markings -> Unmark habitable unit 

 

 

 

 

2. Select the habitable unit that needs to be unmarked and click on finish. 

 

 

 

3. Habitable unit will be unmarked. 



 

 

 

 

 

 

3.17  MODEL STATUS/ERROR SUMMARY 

 

1. After model checking is done, user can view modelling related erros in View Model Status. 
 

2. Error summary provided the details list of all the errors in the model. 
 

3. Floorwise error summay provided the list of errors in that particular floor 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

 

4. Click on floor wise error summary. 

 

 
5. Click on the IDs in floorwise error summary which will track to down to 2D plan highlighting the 

failed object. 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

3.18   Preliminary Rule Check 

 

1. After model checking is done, preliminary rule check report will be generated. 

2. Preliminary rule checks will be done for following rules:- 

 

 Minimum plot area rule. 

 Minimum number of Cellar/basement. 

 Maximum building coverage 

 Maximum FSI. 

 Maximum building height. 

 Maximum floor to floor height in meters. 

 Minimum setback. 
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